B2X300 EC51 Error all steppers

General discussion, news and announcements
Post Reply
jpers
Posts: 2
Joined: 07 Jan 2020, 03:54

B2X300 EC51 Error all steppers

Post by jpers » 08 Jan 2020, 03:50

I recently purchased the B2X300 and just finished putting it together.
I was able to power up and update the firmware. I ran the self diagnostic test and the hot ends, bed heater and the blower all function properly. However, when I run the test on the steppers it fails for an EC51 error and all steppers show "NOK". It fails right away and I do not see or hear anything from the steppers. Do you have any idea what is the issue? I have checked the connections again and see no issue there. Please advise.

srodrigues
Posts: 21
Joined: 04 Mar 2019, 13:41

Re: B2X300 EC51 Error all steppers

Post by srodrigues » 16 Jan 2020, 15:54

The EC51 error indicates some problem with the steppers. You can check the B2X300 user manual at:
https://beeverycreative.com/manuals-tutorials/

The proposed solution if you find this problem is, from the manual:
1. Take note of which stepper drivers are indicates as NOK on the erros screen.
2. Turn off your printer.
3. Check if the previously indicated stepper drivers are correctly oriented and connected to
the motherboard and to the white expansion board which connects all the stepper drivers,
making sure that none of the pins is outside of the connectors.
4. Check if the flat cables that connect the white expansion board to the motherboard are
correctly oriented and connected.
5. Turn the printer back on and run the test again.
Please let us know if with this info you can solve that problem.

Post Reply