[FIXED] X Stepper Driver NOK - EC51

This new DIY 3D printer kit is a result of a vast market research and hours of development and engineering. It is an open source project, which means this is a versatile product that you can build upon and make it your own.
DomingosRodrigues
Posts: 166
Joined: 12 Dec 2017, 11:44

Re: X Stepper Driver NOK - EC51

Post by DomingosRodrigues » 11 Dec 2019, 21:54

Hello gnii,

As long as both ends of the cable are equal on both the motherboard and communication board it should work correctly, as you only need to ensure each cable connects the correct pins :)

Best regards
Domingos Rodrigues

TheDorus
Posts: 1
Joined: 22 Dec 2019, 13:31

Re: X Stepper Driver NOK - EC51

Post by TheDorus » 23 Dec 2019, 08:04

Hello Gni, Domingos,

It seems I have the same problem. After building B2X300, updating the firmware and first power on; a initial self test starts. After heater tests, which are succefull and right after confirming that the blower works the trinamic driver test starts and indicates an EC51 problem on x stepper driver NOK. Perfoming the actions described in the manual didn't solve the problem. Also tips mentioned by Domingos in this forum didn't solve the problem. Time to check if the electronics wasn't the cause of the fault; exchanging the X and Y tmc2130 driver boards resulted in the same error message, no improvement. Just to be sure, I exchanged the E1 and X driver board but the same error message is displayed in the self test sequence.

To check if I could control the stepper motors directly I connected my laptop to the b2x300 trough usb and used Pronterface to send serial control commands to the printer. But it seems the the initial self test (which starts automatically everytime I power on) blocks serial commands, Pronterface is connected, can send commands to the printer, but nothing works (even the heaters, but these work fine in the self test). My guess was that the self test blocks serial communication.

Could this be a firmware issue? Firmware that was installed with the updater software is B2X300-20191202.

Best, Thè

DomingosRodrigues
Posts: 166
Joined: 12 Dec 2017, 11:44

Re: X Stepper Driver NOK - EC51

Post by DomingosRodrigues » 23 Dec 2019, 12:42

Hello TheDorus,

The most likely culprit if you tested the procedures I suggested is a deffective motherboard that cant communicate with the X stepper driver.

You can skip the self test wizard by sending the commenda "M721" when the printer is booting. Although that wont fix the X driver problem.

Please contact customer_service@beeverycreative.com and explain the problem.

Best regards
Domingos Rodrigues

gniiiiiiiiiii
Posts: 18
Joined: 03 Oct 2019, 23:09

Re: X Stepper Driver NOK - EC51

Post by gniiiiiiiiiii » 23 Dec 2019, 12:54

Dear Domingo and TheDorus,

Quick update: after some emails sent to Customer Support, 2 drivers have already been sent and tested, so it seems that Mainboard is defective. I hope there is no bad batch of MB, but only isolated failures.

I'm waiting for the replacement part, but for sure my Christmas projects are down now :(

Anyway, I thank the Support in advance for incoming fix!

Best regards.

gniiiiiiiiiii
Posts: 18
Joined: 03 Oct 2019, 23:09

Re: X Stepper Driver NOK - EC51

Post by gniiiiiiiiiii » 12 Feb 2020, 18:47

Hi,

Still struggling with this issue, trying to send the M721 code to change wizard's flag with YAT but it doesn't work.
Has somebody already made this successfully?
Please let me know what you had on the screen when sending the code.
I've tried when displaying 1st blank screen, little points, the BVC logo, wizard's text... Nothing happened. :cry:

I have to simulate a 6 hours print in order to check if something is burning something else.

Thanks in advance.
Best regards.

Thelaunster
Posts: 10
Joined: 24 Apr 2019, 00:11

Re: X Stepper Driver NOK - EC51

Post by Thelaunster » 15 Feb 2020, 23:18

I too have been experiencing issues with my B2X300 frying multiple extruder stepper drives on me.

I first stepper driver died mid-print. The extruder would not turn during manual extrusion mode. The TMC2130 driver had a clear burn mark where it was soldered to the chip. After sending a picture to customer support, they deemed it faulty and sent out a replacement.

I also bought a few spares online. Troubleshooting this problem I have fried 3 more. All exhibited small black burn speck from where they failed.

I triple checked all my wiring, made sure the power was grounded, carefully installed all new drivers, and unplugged the USB tether to my PC.
After running the diagnostic test, it has been smooth sailing.

My best guess for my situation is that the USB cable may have been getting power from my PC as it power cycled on/off or wake/sleep. This may not entirely apply to you, but it was giving me a headache for months. Printing gcode files off the SD card has proven to be much more reliable for me.

Hope this helps!

gniiiiiiiiiii
Posts: 18
Joined: 03 Oct 2019, 23:09

Re: X Stepper Driver NOK - EC51

Post by gniiiiiiiiiii » 16 Feb 2020, 21:43

Dear Launster,

Yes I have read your post when the problem appeared for 1st time. But unfortunately, or hopefully I don't know :lol: I haven't saw any burnt.

But now here is a great new: I'm pretty sure to have found the problem!

A weld is missing on TMP SPI bus support on X port:
Image

Compared to Y port:
Image

I will fix this tomorrow and keep you updated, but fingers/toes crossed :mrgreen:

gniiiiiiiiiii
Posts: 18
Joined: 03 Oct 2019, 23:09

Re: X Stepper Driver NOK - EC51

Post by gniiiiiiiiiii » 18 Feb 2020, 13:46

Hi,

I confirm that the printer is now working fine after welding back the missing pin.

:D

Post Reply