Search found 18 matches

by gniiiiiiiiiii
18 Feb 2020, 13:46
Forum: B2X300
Topic: [FIXED] X Stepper Driver NOK - EC51
Replies: 17
Views: 1975

Re: X Stepper Driver NOK - EC51

Hi,

I confirm that the printer is now working fine after welding back the missing pin.

:D
by gniiiiiiiiiii
16 Feb 2020, 21:43
Forum: B2X300
Topic: [FIXED] X Stepper Driver NOK - EC51
Replies: 17
Views: 1975

Re: X Stepper Driver NOK - EC51

Dear Launster, Yes I have read your post when the problem appeared for 1st time. But unfortunately, or hopefully I don't know :lol: I haven't saw any burnt. But now here is a great new: I'm pretty sure to have found the problem! A weld is missing on TMP SPI bus support on X port: https://i.imgur.com...
by gniiiiiiiiiii
12 Feb 2020, 18:47
Forum: B2X300
Topic: [FIXED] X Stepper Driver NOK - EC51
Replies: 17
Views: 1975

Re: X Stepper Driver NOK - EC51

Hi, Still struggling with this issue, trying to send the M721 code to change wizard's flag with YAT but it doesn't work. Has somebody already made this successfully? Please let me know what you had on the screen when sending the code. I've tried when displaying 1st blank screen, little points, the B...
by gniiiiiiiiiii
23 Dec 2019, 12:54
Forum: B2X300
Topic: [FIXED] X Stepper Driver NOK - EC51
Replies: 17
Views: 1975

Re: X Stepper Driver NOK - EC51

Dear Domingo and TheDorus, Quick update: after some emails sent to Customer Support, 2 drivers have already been sent and tested, so it seems that Mainboard is defective. I hope there is no bad batch of MB, but only isolated failures. I'm waiting for the replacement part, but for sure my Christmas p...
by gniiiiiiiiiii
11 Dec 2019, 14:56
Forum: B2X300
Topic: [FIXED] X Stepper Driver NOK - EC51
Replies: 17
Views: 1975

Re: X Stepper Driver NOK - EC51

Dear Domingo, I've already sent an email including a link to this post some days ago, but no reply yet. I'll try again with photos and full story, thank you for advice. About flat grey cable: the III cable was "upside down" from factory. I mean the red line was in the opposite direction compared to ...
by gniiiiiiiiiii
10 Dec 2019, 21:43
Forum: B2X300
Topic: [FIXED] X Stepper Driver NOK - EC51
Replies: 17
Views: 1975

Re: X Stepper Driver NOK - EC51

Image
Huho, are 2 drivers deads, now?
by gniiiiiiiiiii
10 Dec 2019, 20:51
Forum: B2X300
Topic: [FIXED] X Stepper Driver NOK - EC51
Replies: 17
Views: 1975

Re: X Stepper Driver NOK - EC51

Dear Domingo, I surely have fooled myself when swapping the drivers. After pulling out all drivers one more time and trying to figure out which pin on communication pcb is linked to each driver, I've carefully installed back each driver. I saw then that on the last driver (fifth from the top), one p...
by gniiiiiiiiiii
10 Dec 2019, 11:30
Forum: B2X300
Topic: [FIXED] X Stepper Driver NOK - EC51
Replies: 17
Views: 1975

Re: X Stepper Driver NOK - EC51

Hello Domingo, It has already been done with no success. Fully removed the mainboard, re-check carefully every connection, especially all the drivers and the white communication board. About the grey cables: they have 2x5 female connectors. The one marked as III is connected to AUX3 port which has o...
by gniiiiiiiiiii
09 Dec 2019, 14:48
Forum: B2X300
Topic: [FIXED] X Stepper Driver NOK - EC51
Replies: 17
Views: 1975

Re: X Stepper Driver NOK - EC51

According to this post: Hello Thelaunster , The EC51 error just means a stepper driver is off, next to the error there should be a message saying which stepper driver is NOK, if the error is always on the same stepper driver even after replacing the E1 stepper for the E2 stepper then it appears the ...
by gniiiiiiiiiii
09 Dec 2019, 10:20
Forum: B2X300
Topic: [FIXED] X Stepper Driver NOK - EC51
Replies: 17
Views: 1975

Re: X Stepper Driver NOK - EC51

I've forgotten to mention that I have swapped the X and Y motors too, and the problem didn't moved.