Fan won't drop under 50%

This new DIY 3D printer kit is a result of a vast market research and hours of development and engineering. It is an open source project, which means this is a versatile product that you can build upon and make it your own.
Post Reply
Alxleitao
Posts: 5
Joined: 22 Feb 2019, 21:18

Fan won't drop under 50%

Post by Alxleitao » 26 Mar 2019, 08:57

I've been having an issue where I've been trying to drop the fan speed to a range between 10-20% and the fan speed on the LCD screen always reads 55% at the least. Additionally I've tried to manually set the speed on the printer itself but it never drops under 55% (140 on the 255-0 scale).

I'm using Cura to slice my models and have checked the gcode myself and M106 is correctly set to the percentage I'm aiming for.

Any help idea what might be the issue?

DomingosRodrigues
Posts: 166
Joined: 12 Dec 2017, 11:44

Re: Fan won't drop under 50%

Post by DomingosRodrigues » 26 Mar 2019, 16:37

Hello Alxleitao,

the blower fan is firmware limited to the speeds it can run at, below 55% the fan would't spin up, or would spin up erratically resulting in burning of it's motor coils and a very inconsistent cooling.

The firmware automatically maps the 0-255 value to 140-255 to use the full range available to the fan.

Best regards

Alxleitao
Posts: 5
Joined: 22 Feb 2019, 21:18

Re: Fan won't drop under 50%

Post by Alxleitao » 07 Apr 2019, 12:07

Ok, fair enough, but I still have issues though.

I set the fan to 57% on Cura when slicing. Check the G code regardless I get the fan spinning at 80% rather than 57%.

Any ideas?

DomingosRodrigues
Posts: 166
Joined: 12 Dec 2017, 11:44

Re: Fan won't drop under 50%

Post by DomingosRodrigues » 08 Apr 2019, 14:18

Hello Alxleitao,

Ignore the value shown on the main screen as that only represents the PWM ammount sent the fan. The real ammount of fan speed, within the range the fan can execute, is the one you set in cura.

Using your example, you request the fan at 57%, the firmware turns the fan on at 57% of its full speed, meaning 80% pwm (57 scaled from 0-255 to 140-255).

We will try to correct the value shown on the main screen on the next firmware release. Thanks for your feedback.

Best regards

Post Reply