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USER GUIDER
1. Software Introduction

1.1 FDM 3D Printer Type

There are sixteen type printers:

FlashForge Adventurer 3/FlashForge Adventurer 3 Lite/FlashForge Dreamer/FlashForge Creator
Pro/FlashForge Inventor Series/FlashForge Finder/FlashForge Guider/FlashForge Guider 1l/FlashForge
Guider Il S Series/FlashForge Inventor |l Series/FlashForge Dreamer NX/FlashForge Creator
3/FlashForge Creator Max/FlashForge Creator Pro 2/FlashForge Adventurer 3C/FlashForge Creator
Max 2

2. Software Installation

2.1 Download

A. Insert SD card sent with Dreamer into a computer, we have already prepare the latest driver
installation package in the SD card.
B. Open below link to download the installation package:
http://www.ff3dp.com/#!sup/cldfl

2.2 Installation & Start

A. Uncompress the downloaded RAR, and complete installation according to the instruction.As for
windows and mac OS, users only need to decompress the RAR/ZIP file and the finish installation
according to the guidelines.

As for the Linux OS, users need to use commands for installation. Place the downloaded .deb file to a
folder or on the desktop, open the command window, enter ‘sudo dpkg -i +the installation package
path’ and then press [Enter] in the keyboard. If any dependency package shall be reminded for
installing, users need to enter “sudo apt-get -f install” to complete its installation.(Note: Linux 14.0
or higher versions are suggested)

B. Connect your Dreamer desktop 3D printer with USB cable and make sure that the printer is
connected to the computer successfully. Start the software with the shortcut on computer desktop
or in the Start Menu. When you first start the software,the following dialog box will pop up for
your machine type choosing.

Note: This software supports Windows XP/Win 7 32-bit and 64 bit/ Win 8 and Mac operating system.


http://www.ff3dp.com/

& Select type of Machine | & |

Machine Type: [Flasl'nl?-:nrge Dreamer "]

Fleazse =zelect the machine type first. You can change the
machine type wia [Frint]->[Machine Type] on the menm bar.

|

When open FlashPrint, Happy3D Pop-Ups will appear automatically. After check 'Do not show this

message ',Happy3D Pop-Ups will not appear. Click the button of 'More details ',according to computer
language setting, Flashforge official website in Chinese or English will open. (Flashforge official Chinese
website only open in Computer with Chinese language setting, while it will open Flashforge official
English website in default.)

HAPRY. 30 APP

Easily ta desian and edit
2D madels!

[(EEe]

[T Mor*t =how this message again



3. Software Operating Instructions
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FlashForge Dreamer

Load into one or multiple files.

Enter supporting editing mode

5

View models from one of the six viewing angels. (shortcut:keyboard—V)

Move model around on xy-plane; shift+click to move along z axis (shortcut:keyboard—M)

Turn and rotate your model (shortcut:keyboard—R)

Scale the size of your model (shortcut:keyboard—S)

Select right or left extruder you want to print with (shortcut:keyboard—E)
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l!,' Print it directly with your Dreamer or export to your SD card.
Z To cut the model from different directions. (shortcut:keyboard—C)

You can use Flashprint software to control and perform printing tasks.

3.1 Load File

You can load a model file or Gecode file into the software by following six methods:

A. Click the “Load” button on top of the software interface. Then select the file which is
needed for loading.

B. Select the file which is needed for loading, and then drag the file to the interface of the
software.

C. Click the “File -> Load File” menu. Then select the file which is needed for loading.

D. Click the “File -> Examples” menu. Then select the file which is needed for loading.

E. Click the “File -> Recent Files” menu. Then select the file which is needed for loading.

F. Select the file which is needed for loading, and then drag the file to the icon of the

software.

You can load into .stl, .obj, .fpp ,.3mf, .png, .jpg, .jpeg, .slc or .omp model files which are editable in the
software. Please refer to Chapter 2.2~2.5 and you can find instructions of that modification, such as
operations of mouse, changes of view from different angles and how to edit and save the file. After
modification, please refer to Chapter 2.6 if you want to slice the model file , generate Gcode file and Print
it.

Important Note: Gcode file can not be edited any more, but you can directly start the printing after
loading it into the software. Please refer to the Chapter 2.6.1 and 2.6.2.2 which tells you how to connect

to Dreamer and how to print the Gcode file.
3.1.1 Generate Relievo

Relievo is transformed from png, jpg, jpeg and bmp files. The png, jpg, jpeg or bmp file could be
transformed into stl. file and loaded into the slice software for application.

which includes settings for shape, mode, maximum thickness, base thickness, bottom thickness,width,

height, top diameter,Graphic pattern height,equatorial diameter,enable ellipsoid and bottom diameter.
Shape: including plane, tube, sphere,canister,lamp and seal.

Mode: including “darker is higher”and “lighter is higher”.

Maximum thickness: Z value of the model.

Base thickness: The minimum raft thickness and the default value is 0.5mm.

Width: X value of the model.

Depth: Y value of the model.



Bottom thickness: For tube, canister and lamp to set up bottom thickness.

Top diameter: For tube, canister and lamp to set up the top diameter.

Bottom diameter: For tube, canister and lamp to set up the bottom diameter.
Graphic pattern height: The maximum height of the stamped graphic pattern.
Equatorial diameter: spherical equatorial diameter(inside diameter)size.

13 2

Enable ellipsoid:including two choice:yes,no.Choose yes = ,then generating corresponding ellipsoid
according to image loaded(the polar diameter confirmed by the image scale of uploaded image);Choose

<

no’ ,then generating sphere according to image loaded.

The effect pictures for different shapes:

& Convert image to dlL " X

Shape: = o] >,
Mode: Sphere

Equatorial Diameter:

Base Thiclmess:

Maximum Thiclmess: &. 80mm

{2

Enable Ellipscid:

[
i
(1]
4

| & || cenca |

The loaded original png picture:




(Plane)

(Tube)
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3.2 Mouse Operations

3.2.1 Left click

A. Select a model by moving the mouse to it and just left click it.

B. Select multiple models by holding the Ctrl key and left click models you want.
C. Model looks brighter when selected.

D. Model can be edited when selected.

E. Left click blank space to undo the selection of model.



3.2.2 Left click and hold the left button

When changing the viewing angles or editing models, different effects appears by left-clicking and
holding the left button. Please refer to Chapter 2.3.1~2.3.2 & 2.4.

3.2.3 Right click and hold the right button

Same results in any operations when right clicking and holding the right button. Please refer to the
Chapter 2.3.1 & 2.3.2.

3.2.4 Scroll the mouse wheel

Same effects in any operations when scrolling the mouse wheel. Please refer to the Chapter 2.3.3.

3.3 Change Views

You can choose perspective or orthographic. Change your view of the model by moving, rotating,
scaling the view and so on.

3.3.1 Move

You can move the view of printing frame in the software interface by following three ways:
A. Long-press the left button of mouse and drag.

B. Press and hold the middle button of mouse, and then drag the mouse.

C. Hold the Shift key, long-press the right button of mouse and drag.

3.3.2 Rotate

You can rotate the view of printing frame in the software interface by following two ways,
A. Long-press the right button of mouse and drag.
B. Hold the Shift key, long-press the left button of mouse and drag.

3.3.3 Scale

You can scale the view of printing frame in the software interface by scrolling the mouse wheel or use
the ‘+/-" shortcut in any condition.

3.3.4 Set

You can set the view of printing frame in the software interface from six angels by following three
ways to observe the model.(Top/Bottom/Front/Back/Left/Right View) .

A. Click the View menu, and then select the view you need to observe the model.

B. Click the Look button on the left of the software interface, and select the view you need.

C. Select and double click the border of build plate to switch views.

3.3.5 Reset

A. Click the View menu, and then select Home view to reset the view.
B. Click the Look button on the left of the software interface, and then click Reset button to reset it.

3.3.6 Show Model Outline

Click the View -> Show Model Outline, it will highlight the outer surfaces of your model file with gray
and white color.



3.3.7 Show Steep Overhang

Click the View -> Show Steep Overhang->Enable/Disable menu . When the intersection angle
between the model surface and horizontal line is within the overhang threshold value, we say the
surface has steep overhang and it becomes red in the software. Overhang threshold value could be

set as needed. The default value is 45 degree.

& Set Overhang Threshold -S|

Owerhang Threshold: 457 =

3.4 Edit Models

You can edit the models by moving, rotating, scaling the model and so on.
3.4.1 Move

When the model is selected, you can change model location on the build platform by the following
two ways:

A. Click Move button on the left of the software interface. Long-press the left button of mouse and
drag, you could adjust the location of the model in XY direction. Hold the shift key, and long-press
the left button of mouse and drag, you can adjust the location of the model in Z direction. You can
see the distance and direction of the movement which refers to the relative distance between
present and former location.

B. Click Move button on the left of the software interface and then enter the distance value you
want to move on X/Y/Z axes positioning. Click Reset button to reset distance values.

Note: Generally, we suggest you to click the Center and On Platform buttons after adjusting location
of the model to make sure the model within the printing scope and sticking to HBP. Only click On
Platform button if you want to print the model in a specified position.

3.4.2 Rotate

3.4.2.1 When the model is selected, you can change the orientation of your model on the build platform
by following two ways:
A. Click Rotate button on the left of the software interface and you can find three mutually
perpendicular rings whose color is red, green and blue. Click one ring and rotate on the present axis,
you will see the rotation angle and direction in the center of circle. In this way, you could make the
model rotate on X/Y/Z axis.
B. Click the Rotate button on the left of the software interface, and then enter into rotating angel
values in X/Y/Z axes positioning. Click Reset button to reset rotating angel values.
3.4.2.2 Set side flat
After choosing model, operate as below to set side flat
@ check”Rotate->Set side flat” ;
@ Choose the side of model by mouse, double click the left mouse button on mouse floating side,
the model side will be automatically set as flat, the selected side will plying-up bottom board.

10
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FlashForge Dreamer

3.4.3 Scale

When the model is selected, you could change the size of the model on the build platform by the
following two ways.

A. Click Scale button on the left of the software interface, then press the left button and move the
mouse to adjust the size of the model. You will see corresponding values of different axes near the
borders.

B. Click Scale button on the left of the software interface, and then enter into scale values in X/Y/Z
axes positioning. Click Maximum button to get largest size possible for building. Click Reset button to
reset the size of model.

Note: Select Uniform Scaling option, it will scale the model in equal proportion when changing value
in any positioning of the model. Not select this option, it will only change the value of the
corresponding positioning.

3.4.4 Set

When the model is selected, click Extruder button on the left of the software interface and select the
extruder you want to print with. The model will turn purple if you choose left extruder or gray if right
extruder. If you choose ‘FlashForge Adventurer 3/FlashForge Adventurer 3 Lite/FlashForge
Finder/FlashForge Guider/FlashForge Guider ll/FlashForge Guider I S Series/FlashForge Inventor Il
Series/FlashForge Dreamer NX/FlashForge Adventurer 3C’, the software will be unavailable for nozzle
setting and the default nozzle setting shall be “Right Nozzle”.If you choose  ‘Flashforge Creator
3/FlashForge Creator Pro 2/FlashForge Creator Max 2’ , you can select duplicate or mirror according
to your need to print using dual extruder in the meantime(choose  ‘use dual extruder

(duplicate)’ ,then dividing the build plate into two same printing area,generating two same models
limited by the vertical plane in the build plate;choose  ‘use dual extruder(mirror),then generating
symmetrical models limited by the vertical plane in the build plate)

11



If a model can be printed with dual extruders or the support is needed to complete the printing, you
can use dual extruders to print it with different color filaments or even different kinds of filament.
However, dual extrusion printing is not available when the model can only be printed with one
extruder. You need to know whether the model diagraph has single or dual colors when selecting the

model. Dual-color model is combined with two single color models.

Note: When setting the extruder, mouse operations are same as those of changing views. Please refer
to the Chapter 2.3.1~2.3.2.

3.4.5 Cutting the Model:

Left-click to select the target model and then click the [Cut] icon on the left to enter the Cut
mode(Shown as follows). Users can set up the direction(Free-hand plane, X plane, Y plane, Z

plane) ,position and keep parts in place.
.. . oo

& FlashPrint - untitle fpp* - o TR S R

File Edit Print View Tools Help

Load

-
Frint

Supports

FlashForge Dreamer

Free-hand plane: Left-click to select the target model and hold down the left mouse button to draw the
cutting line (The cutting line will turn into a facet later). To change the position of the facet, users can(1)
left-click to select the facet and hold down the left mouse button to drag the facet. (2) change the position
values, then click the [Start Cut] button or double-clickthe model .

(Before Cutting) (After Cutting)
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X, Y or Z Plane: Select the X, Y or Z plane in the Direction drop-down menu . Left-click to select the
target model and the software will automatically generate the facet according to the cutting position.To
change the position of the facet, users can(1) left-click to select the facet and hold down the left mouse
button to drag the facet. (2) change the position values, then click the [Start Cut] button or double-clickthe

model

e ::: ESSESESSSSS
7 -

X B e e e e
VAR A A RN [N [N [N [N N N N T O W
7 A 7 (Y [ (I N [ T |

(Z Plane)
Keep parts in place: After finished cutting, the new model will be in their original position won’t be

shifted automatically anymore.

(Contrast pictures:Choosing function of keep parts in place or not)

3.4.6 Others

3.4.6.1 Undo

Undo the most recent edit you made to your model file by following two ways:

A. Click Edit-> Undo menu.

B. Use the shortcut Ctrl+Z.

Note: Selecting this option multiple times will continue to undo edits in reverse order in
Which they were performed.

3.4.6.2 Redo

Redo the most recent edit you have undone to your model file by following two ways:
A. Click Edit-> Redo menu.

13



B. Use the shortcut Ctrl+Y.
Note: Selecting this option multiple times will continue to redo edits in reverse order in which

they were removed.
3.4.6.3 Empty Undo-stack
To clean up the recorded operating steps so as to release the memory.
3.4.6.4 Select ALL

By the following two methods, you could select all models in the scene.

A. Click Edit-> Select ALL menu.

B. Use the shortcut Ctrl+A.

Note: When models are too small to be seen or out of viewing scope, please click Center and On
Platform buttons after selecting all models to bring them to the printing scope.

3.4.6.5 Duplicate

After model is selected, you can duplicate it by the following two methods:
A. Click the Edit-> Duplicate menu.
B. Use the shortcut Ctrl+D.

3.4.6.6 Delete

After model is selected, you can delete it by the following two methods:
A. Click the Edit-> Delete menu.
B. Use the shortcut Del.

3.4.6.7 Automatic put

After loading one model or several models, press”Edit->Automatic placing” and fill in space between
models(0-50mm), all models will will be put in position according to the automatic put rule.

€ Auto Layout All L ]

Space Between Models: S0, Omm b=

3.4.6.8 Mirror

To make mirror image in X-axis, Y-axis and Z-axis for the chosen model.
3.4.6.9 Model Repair

The software will detect the model when loading the model. If any problem is detected, a dialog box
will pop up for reminding the users. Users can click the “Repair Model” button or select the model,

click [edit]--[model repairing] to repair the model.

+ Undo Crl+Z
=+ Redo Ctrl+Y
Empty Undo-Stack

6 Warning m- — Prm: View Tools Help

Select All Ciel+A
Duplicate Ctrl+V

'0' Errors has occured to the model. You can

Delete Del

Auto Layout All

Mirror

Repair Models

Supports

[Repair model] [Delete mu:-del] ‘ Iznore
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3.4.6.10 Wiping Tower
After importing the model, tap ‘Edit->Wiping Tower’ , enter wiping tower editing interface.

—

0 FlashPrint - untitle.fpp*

File Edit Print View Tools Help

| | Wiping Tower il | |
| | Optiens e | |

@

|
Add | | ‘ |

©

Delate 1

FlashForge Finder

single extruder 3D printer ,Support to set wiping tower size, Number, Base Size and shell thickness in
wiping tower options, The default wiping tower height is the same as that of the loaded model.If multiple

models exist, take the height of the highest model.

&> Wiping Tower Options & Y S

Size: 15. Omm =
Base Si1ze: 25. Omm =
Shell Thickmess: 2. 5mm =

[ 0K J [ Cancel ] lRestnre Defaults]
| _l

dual extruder 3D printer, Support to set wiping tower size, Base Size and shell thickness in wiping
tower options, The default wiping tower height is the same as that of the loaded model.If multiple models

exist, take the height of the highest model.

€ Wiping Tower Gptiuns__g ||

Humber : Z =
Size: 15, Omm =
Baze Size: 25 Omm =
Shell Thickmess: 2. Smm =

[ 0K ] [ Cancel ] lRestnre Defanlts

After setting the parameters of wiping tower, click 'add' button, move the mouse to select the

15



coordinates of wiping tower, and click the left mouse button to add the wiping tower.
When the number of the wiping tower for a double-extruder 3D printer is 2, it permits to set a single
left or right wiping tower or set two together.

e S— eI

File Edit Print View Tools Help

6 FlashPrint - untitle.fpp*

\ | Wiping Tower
| | e Back | |

€&

Delete ‘I F . J

FlashForge Finder

@ FashPrint - untitledfppr” TR W B @R TROE . - PR

File Edit Print View Tools Help
.

Wiping Tower
Options

Back

/\
/ \ |
# \‘.‘ [
i
#dd Right / \ J{

Add Left

Delete

FlashForge Dreamer

click 'delete' when needing to delete the wiping tower , select the wiping tower with the left left
mouse button, delete successfully.
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3.5 Edit Supports

II
After model file is loaded, click Edit->Supports in the top menu, or press button in homepage, you can

edit the support structures of your model. Click Back on the top-right corner to exit when finishing the
edits.

v’rlashprint-umi‘té:fpp* T — . R =a] x |
Ele Edit Print View JTools Help
3, 30,00
e 8 A\ g -
= | —

\ Supports  Auto Clear Back | =

Options  Supports Supports

FlashForge Dreamer

3.5.1 Auto Supports

Select this option to have your model build with support structures. FlashPrint software will automatically
generate treelike, Linear, columnar support, and it will generate new support structures to replace original
ones included in your model file.

3.5.2 Clear Supports

Select this option to empty all the supports of your model. Click Edit->Undo in the menu or Ctrl+Z to

undo this operation.

3.5.3 Add

Select this option to add supports (shortcut:keyboard—A) . After selecting this option, move the
mouse to where you want to add the support, and then left-click the mouse to select the start point

17



of support structure. Press and hold the left mouse button down, drag the mouse, and then you can
preview the support structure you will add (If the support surface does not need to support or the
angle of support column is too large, the previewed support structure will be highlighted.) Release
the left button of mouse to add this support, the support structure will be generated according to
the start and the end position. But if the support column intersects with the model or the previewed
support structure is highlighted, support structure will not be generated.

Choose "show model slice outline" on the view menu bar, when the mouse pointer moves to the mo
del, display the corresponding model cross-sectional outline on which the mouse points, in order to b
etter observe and select support position.

3.5.4 Delete

Select this option to delete supports (shortcut:keyboard—D) . After selecting this option, move the
mouse to the supports you want to delete, then left-click the mouse to delete it. Press Ctrl button
and mouse left to delete support in region selection.

3.5.5 Model Select

Select this option to Model select supports (shortcut:keyboard—S) .Only add Auto Supports or do
Clear Supports to the selected model. Add different support-settings for different models when print
file include more than one model.

3.5.6 Support option

3.5.6.1 FDM 3D Printer
Click [Supports Options] and then a dialog box will pop up for supports type selection and parameter
settings. Linear and treelike supports are available for selecting. If you select ‘Treelike Supports’, you
can setup the parameters of overhang thresh, post diameter, base diameter and base height, and
then click [OK] to confirm. If you select ‘Linear Supports’, you can setup overhang thresh and pillar
size, then click [OK] to confirm, when choose Linear, output is Linear structure. If the model already
has support, when you choose support type, the software will judge the existing support type and
decide if it is necessary to delete these supports. It will jump out reminding, you can operate as you
Need. (Note:

Overhang thresh: To setup an angle value. If you input 45, then when it comes to a 3D

model with an overhang of 45 or more than 45 degrees. The system will generate supports for these
positions. The value extends from 30 to 60.Post diameter: The diameter of the treelike supports.
The value range is 1-6mm. Base diameter: The diameter of the support raft. The value range is
3-10mm.Base height: The height of the support rafts. The value range is 1-6mm.Pillar size: The side
length of the square column.Touch Platform Only: Only create the supports contact with the build
plate.)

€ Supports Options LX) € Supports Options X

Supports Type: @ Treelike ) Linear

Overhang Thrashald: | |30° Supports Type: ) Treelike @ Linear

Post Diameter: 3. Omm = Owerhang Thresheld: 30° -
Base Diameter: &. Omm = Pillar Size’ 1.5mm e
Base Height: 6. Omm e

Touch Platform Only: M
Touch Flatform Only: |

| 0K J [ Cancel | lRestore Defaults| | 0K I [ Cancel | IREStDrE Defaults
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3.6 New Project

Click File -> New Project to create a new project. If your current project hasn’t been saved with changes, it
will pop up a dialog to prompt you to save them. Click Yes button to save those changes, click No button to
discard them, Click Cancel button to close this dialog and it will not create a new project.

£ Infarmation S

'6' Save changes to this file before closing?

l Yes I l Mo | | Cancel

3.7 Saving File

You can save changes of your model files by following two ways:
A. Click File -> Save Project to save your file only with .fpp format. All the models(including supports)
in a .fpp format file are independent and they can be edited again when reloading the file. Besides,
extruders’ configuration and models’ locations remain same as saving the file.
B. Click File -> Save As to save your file with .stl, .obj,.3mf or .fpp format. All the models in a .stl
or .obj format file are not independent, but combined to a new model. Models’ locations remain
same as saving the file, while extruders’ configuration becomes different when reloading the
file.When a model with main part and support need to be saved, it is recommended to save the file
as .fpp format. If you save the file as ".Stl", ".Obj"or".3mf", The model and the treelike supports in
the plate are not independent of each other, while the model and the linear supports are
independent of each other, the liner supports won’t be saved with the model. The software will not
be able to distinguish the original file model from the support and print Quality will be affected.

3.8 Printing Process

3.8.1 Choose Machine Type

Click Print-> Machine Type to choose the machine type you have before connecting to the printer, or
the FlashPrint will automatically recognize the machine type after connecting, in this case you can
not manual switch to other machine type(s). Different machine types have different machine frames
which will affect sliced file(s).

If the selected machine type is ‘FlashForge Guider Il S Series/Creator 3/Adventurer 3’, the nozzle size
of the printer can be selected in the "Print-Nozzle Size" expanded item.

3.8.2 Connect Machine
Please refer to Chapter 2.9.1.1 for configurations of connecting to Dreamer 3D printer.
3.8.3 Print

3.8.3.1 FDM 3D printer generate Gcode file
In order to print, you need to slice the model file to generate gcode file. Configuring slicing
Parameter and generating slicing files by following steps.

1. Click Print -> Print menu or Print button on top of the software interface, it will pop up a dialog
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box for slicing. If users choose ‘Flashforge Dreamer/Flashforge Creator Pro/FlashForge Inventor

Series/Flashforge Creator 3/Flashforge Creator Max/FlashForge Creator Pro 2/FlashForge Creator

Max 2’, the corresponding dialog box of slice parameters shall be “figure 1”. If users choose

‘FlashForge Adventurer 3/FlashForge Adventurer 3

Lite/FlashForge Finder/FlashForge

Guider/FlashForge Guider ll/FlashForge Guider Il S Series/FlashForge Inventor II

Series/FlashForge Dreamer NX/FlashForge Adventurer 3C’, the corresponding dialog box of slice

parameters shall be ‘figure 2".

0 Print

(S

I want to: LjJI FPreview

Machine Type: FlazhForge Dreamer

D Print When Slice Done

Material Right: [ABS |
Material Left: [ABS |
Supports: IDisable hd |
Raft: [Disable -
Besolution: ) Low (Faster) [T] #a11
@ Standard El Vaze Mode
©) High (Slower)
Layers | Shells | Infill | Speed | Temperature | Others | |
Layer Height: 0. 20mm £
First Layer Height: 0. 30mm = |

Restore Defaults

(1):4 ] [ Cancel I Save Configaration
(figure 1)
& Print -— Xl
I want to: |_7_| Prewiew D Frint When Slice Done

Machine Type: FlaszhForgze Finder

Material Type: [EL&
Supports: [Disable
Raft: [Disable

Resolution: () Low (Faster)
@ Standard
() High (Slower)

") Hyper

More Optioms >3

[ wa11
D Yaze Maode

f Layers | Shells | Infill

Speed I Temperature

Layer Height:

First Layer Height:

0. Z0mm

0. 30mm

4l

Restore Defanlts |

0K

] [ Canecel ‘ ISave ConfigurationJ

(figure 2)
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2. Set slicing parameters and click Ok button, and it will pop up a dialog box for saving Gcode file.

3. In the Save as dialog box, select the path for saving the Gcode file, and then click Save button. You
can see the bar at the bottom of software interface start to show the completion progress of
slicing, which means it is slicing and uploading Gcode file now. Click Abort button on the right side

of the process bar to give up slicing.

TF]asthnt—unlltie_JE! e a & -&=M‘- ————— i -

File Edit Print View Tools Help

Supperts

Extruder

Slicing model. ..

3.8.3.2 Explanation of standard Slicing settings
o [=[E] = ]

e fp

4 FlashPrint - i

[ Print W}L Slice Done

T want to: Pr&/izw

Material Right: [ABS

Material Left: [ABS -]

(i) e Suppor ts [Dizable -

- Raft: Dissble -
._I_. N [ J

wpResolution: ) Low (Faster) [] Wall
Hove @ Standard [T Vaze Modagume— |
) High (Slower)

C [rors bptacas 7] !
Fotate Layers | Shells | Infill | Spsed | Tenpsrature | Dthers

Layer Height: 0. 20mm

[ BBl

First Laysr Height: 0. 30mm

Restore Defanlts
e Gt

Extruder

ashForge Dreamer
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A.Floating boxes for slicing proper nouns:Move the cursor to the specific position that a slicing
proper noun or a parameter lies and linger for a while, a floating box will appear with the
explanation inside.

B. Preview: Select this option to preview the Gcode file when slicing finished.

C. Print When Slice Done: Select this option to directly print the model.

D. Material Right: Choose filament type you want to print with right extruder.

E. Material Left: Choose filament type you want to print with left extruder.

Material Type:Select the appropriate nozzle and material according to the settings of nozzle.

If users choose ‘Flashforge Dreamer/Flashforge Creator Pro/FlashForge Inventor Series/Flashforge

Creator 3/Flashforge Creator Max/FlashForge Creator Pro 2/FlashForge Creator Max 2’, select

corresponding material for the ‘left/right extruder’. If users choose ‘FlashForge Adventurer

3/FlashForge Adventurer 3 Lite/FlashForge Finder/FlashForge Guider/FlashForge Guider

Il/FlashForge Guider Il S Series/FlashForge Inventor |l Series/FlashForge Dreamer NX/FlashForge

Adventurer 3C’, select corresponding material .

F. Supports: Used to hold the overhangs of model.Choose Left or Right Extruder to print supports

when overhang is existing, or Disable when no need.

Click the [Supports] button, if the machine type is ‘Flashforge Dreamer/Flashforge Creator
Pro/FlashForge Inventor Series/Flashforge Creator 3/Flashforge Creator Max/FlashForge Creator
Pro 2/FlashForge Creator Max 2’, select left/right extruder for supports adding. If the machine
type is ‘FlashForge Adventurer 3/FlashForge Adventurer 3 Lite/FlashForge Finder/FlashForge
Guider/FlashForge Guider Il/FlashForge Guider Il S Series/FlashForge Inventor Il
Series/FlashForge Dreamer NX/FlashForge Adventurer 3C’, choose ‘Able’ or ‘Disable’ for
supporting setting.

G. Raft: Creates a raft below the model which can help with adhesion and tolerance for non-perfect
build plates. Choose Left or Right Extruder to print raft which can make the model attach well to
the build plate, or Disable when no need. Click the [Raft] drop-down button, if it is ‘Flashforge
Dreamer/Flashforge Creator Pro/FlashForge InventorSeries/Flashforge Creator 3/Flashforge
Creator Max/FlashForge Creator Pro 2/FlashForge Creator Max 2’, choose left/right extruder for
raft setting. If it is ‘FlashForge Adventurer 3/FlashForge Adventurer 3 Lite/FlashForge
Finder/FlashForge Guider/FlashForge Guider Il/FlashForge Guider II S Series/FlashForge Inventor
Il Series/FlashForge Dreamer NX/FlashForge Adventurer 3C’, choose ‘Able’ or ‘Disable’ for raft
setting.

H. Wall: Creates a wall around the model to scrape oozing from the idle extruder. It's suggested to

enable in dual extrusion printing.

L. Brim: Expand the outline of model’ s bottom layers to a Brim which helps anchor the edges of
the model to the plate to avoid warping.

J.Vase mode: It can be used to print the single layer model without seams. Under this circumstance,
the number of perimeter shells is constant to be 1, the density of infill is constant to be 0, and the

number of top solid layers is default to be 0.
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K. Resolution: When printing right extruder with ABS or dissolvable filament, you can select
High option with better print but lower speed, or Standard option, or Low option with normal
print but high speed. Each option has its own configured parameter. While printing right
extruder with PLA filament, you have the fourth option, which is Hyper with hyperfine print.
If users choose ‘Flashforge Finder/Guider’, users only need to set up the nozzle temperature

according to the material. The nozzle temperature for PLA is recommended to be 220°C.

\ A B High((Slower) o F |

. Layers Shells ’ Infill ’ Speed ’ Temperature [ Others |

Layer Height: 0. 20mm =

First Layer Height: 0. 30mm

:Restore Defaults

i Ok ] 'L_ Cancel | Save Configuration

Click More Option button to set the parameters as you want. Different resolutions have different
default parameters. Click Restore Defaults to restore it.
A. Layers
a. Layer Height : Thickness of each layer. The less thickness of layers, the more time will be
used and the better model will be printed .

b. First Layer Height: =~ When printed with thinner layers, comparative thicker bottom layer

could improve adhesion and tolerance for non-perfect build plates.
B. Shell : Including outside shell quantity, sealing top layers, sealing bottom layers(When Vase
model selected, sealing top layers invalid)

a. Outside shell quantity:Number of paths superimposed for building the shell, more paths
make thicker shell.

b. Sealing top layers: Number of solid layers on the upper surface of model.

c. Sealing bottom layers: Number of solid layers on the under surface of model.

C. Infill

a. Fill Density :Determines the interior solidity of the model.

b. Fill Pattern:Determines the infill pattern for the interior of model. Hexagon infill is with the
highest strength while line infill is with the shortest print time. Triangle infill takes slightly
more time than line infill, but with more cohesiveness between layers,3D Infill is a 3D spiral
infill shape,generally used when infilling density is lower,and it is recommended to turn off

combined infill function.

c. Combine Infill: This option allows to combine infill and speed up your print by extruding
thicker infill paths. If layer height is larger than 0.1mm, “Every N Layers” is suggested,

otherwise, “Every N Inner Layers” is suggested.
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Fill Density: 15% 5
Fill Fattern: [Hexagnn TJ
Combine Infi1ll: |Ever}' 2 Sparse Layers ‘"|

D. Speed

a. Print Speed: Used to calculate movement speed during extrusion. The slower the speed is,
the more time will be used and the better model will be printed..

b. Travel Speed: Speed at which extruder moves when not extruding filament.

Note: Recommend set the empty speed at 80, printing speed at 60 when use PLA,
ABS,HIPS,PA,PC,PETG, Wood and conductive PLA filament printing, use flexible material set
empty speed at 70, printing speed at 20,use PA set empty speed at 70, printing speed at 50.
Different model have different model parameter, several attempts to find the suitable
Parameter.

Different types of printing material and different quality of slice project, the speed value of
configuration will be different, users can get the recommended values of different schemes in the
default configuration.

E. Temp.

a. Extruder
Set proper printing extruder temperature, according to material. The maximum temperature
is 255°C and the hint message will appeared when nozzle temperature is over 245°C..If the
machine type is “FlashFoge Dreamer/ FlashForge Creator Pro/ FlashForge Inventor
Series/Flashforge Creator 3/Flashforge Creator Max/FlashForge Creator Pro 2/FlashForge
Creator Max 2” dual extruder 3D printer, Users can set the temperature of dual extruder. As

shown below:

Layers | Shells | Infill | Speed | Temperature | Others
1 1 -

Eight Extruder: 22070 i
Left Extruder: 22070 i
Flatform: 105 i

If the machine type is “FlashForge Adventurer 3/FlashForge Adventurer 3 Lite/FlashForge
Finder/FlashForge Guider/FlashForge Guider Il/FlashForge Guider Il S Series/FlashForge
Inventor Il Series/FlashForge Dreamer NX/FlashForge Adventurer 3C” single extruder 3D

printer, the setting interface as follow:

Layers I_-S-i'Lells i_I;flll_I_-Spe_ed_| Temperature ll Others i

Extruder: ol ) =

b.Set the temperature for left or right extruder and platform. Set 220 to the
extruder temp for ABS,conductive PLA and flexible material printing. Set 50 to the platform
temp for PLA,conductive PLA and flexible material printing ,while 105 for ABS printing. Set
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(left: 240, right: 220) to the extruder temp for dissolvable Filament printing,Set 105 to the
platform temp .If users choose  ‘FlashForge Adventurer 3/FlashForge Adventurer 3
Lite/FlashForge Finder/FlashForge Guider/FlashForge Guider IlI/FlashForge Guider Il S
Series/FlashForge Inventor |l Series/FlashForge Dreamer NX/FlashForge Adventurer 3C” , users
only need to set up the nozzle temperature according to the material. The nozzle temperature
for PLA is recommende to be 220°C, Conductive PLA and flexible material temperature is
recommended to set at 230°C.
Adjust the temperature according to the condition in order to get a good print.
F. Others
a. Cooling fan controls:Set up the time to turn on the cooling fan. Only used for
FlashForge Adventurer 3/FlashForge Adventurer 3 Lite/FlashForge Dreamer/FlashForge
Creator Pro/FlashForge Guider II/FlashForge Guider Il S Series/FlashForge Inventor
Series/Flashforge Creator 3/Flashforge Creator Max/FlashForge Adventurer 3C/FlashForge
Creator Pro 2/FlashForge Creator Max 2 at present. You can pre-set the height and make the
cooling fan begin to work at the point.

More Options ?}

|-I._.a}'er ]'t;ght | Shell=s | Infill | Speed I Temperature Others |_

Cooling Fan Contrels: ﬁ;ut,u_:-mat,n_’.jh -
Pauze At Heights: Mways On
Mway=s Off

0N (when raft bottom printed)
OF (when to pre—set height)
0N (while printing raft top)

|Restnre Defaults

More Options

| Layer Height i_Shells I Infi1ll I Speed I Temperature | Others |

Cooling Fan Controls: IEIH [when to pre—set height) Tl

The Pre—set Fan On Height: 0. 00mm 5

b.Suspend at a Certain Point: Turn on the cooling fan when to specific height.Users can add

one or more specific height values(no higher than the model height). It displays as follows.

| Layers I Shells I Infill I Speed I Temperature | Others [

Pause At Heights: |10. Omm [ Eaie |

Steps: Click the [Edit] button, and a box will pop up(See graphic below). Then add the value,
click [+] for confirmation, and the value will show in the list of [Delete Value]. If deletion is
required, select the specific value on the list and click [-] for confirmation. Click [OK] to finish

and exit these steps.
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4 Pause At Heights e S

£dd Fause Height: 10.0mm (5 +

Remowe Fause Height: llEl.Dmm v] [ = l

| ok || Cancel |

3.8.3.3 Explanation of Expert Slicing settings

& Print (Expert Mode) N, ™ gy |
I want to: [#] Preview [ Frint When Slice Done
| | sereet Prosita: [Dreamer PLA v | [Standara v ) [ save A= Hew | Eemovs

General | Perimeter | Inf£ill | Supports | Raft | Additions | Ceoling | Advanced | Others

Layer Height Speed

Layer Height Mode: Fixed Layer Height ¥ | | Base Print Speed: EOmm, = <

Layer Height: 0. 18mm = Trawel Speed: S0mm, = =

First Layer Height: 0. 2Tmm = Minimum Speed: Emmy = =
Tdit Varisble Layer Height First Layer Maximun Speed: 20mm/s =

First Layer Maximum Trawel Speed: TOmm/s
Retraction

Temperature

|
| FRetraction Length: 1. 3mm =

Speed: R = Right Extruder: 200°C =

Flatform: s50°C =
| Adapt Scluble Suppert Filament
| [Eva = Adapt ]
Restore Defaults
[ ok ][ Cancel | [Save Configuration

A. Preview: Select this option to preview the Gcode file when slicing finished.
B. Print When Slice Done: Select this option to directly print the model.
C. Select Profile:
D. General:
1. Layer Height:
a. Layer Height Mode

1. Fixed Layer Height

2. Variable Layer Height: click “various layer height ”and “Edit variable layer height ”,

pop-up variable layer height editing dialog box

(1) Add/Delete icon: Click the icon, pop-up variable layer height editing dialog box,
which can add or delete the variable layer height in the specified height.

(2) The model layer height column: right click the model layer height column and
Add/Delete icon, then pop-up variable layer height editing dialog box. The default added
height is the height mouse clicked. The default deleted height is the closest height has been
added as various layer height.

(3) click “Done” button and enter the expert mode setting dialog box.

26



Feneral | Ferimeter I Infill Supports I Rafi

Lawer Height

Lawer Height Mode: tﬂ’griab;lr.e Layer Height "’]
Fixed Layer Height

Layer Height:

¥ariable Layer Height

First Layer Height: 0.2Tmm

My

Edit Variable Lawer Height

0 FlashPrint - untitle.fpp*

| 1

Il hddfRemove  Done [

|
|| | |
|1 I I
l‘ ‘l 0 Add/Remove Layer Height 2 |

Add Layer Height:  31.5mm [3] 15% [3]

Remove Layer Meight: [3L.3nm, 15% =) [ )

FlashForge Guider II

b. Layer Height: Thickness of each layer. The less thickness of layers, the more time
will be used and the better model will be printed.
c. First Layer Height: When printed with thinner layers, comparative thicker bottom
layer could improve adhesion and tolerance for non-perfect build plates.
2. Speed:
a.

Base Print Speed: Base speed at which extruder moves during extrusion, which is
the base value of subsequent speeds counting.

b. Travel Speed: Speed at which extruder moves when not extruding filament.

c. Minimum Speed:The minimum movement speed during extrusion..

d. First Layer Maximum Speed:To limit the print speed of first layer, which will help
with adhesion. When enabling Raft, this limit will not apply.

e.

First Layer Maximum Travel Speed:To limit the travel speed of first layer, which
will help with adhesion. When enabling Raft, this limit will not apply.
3. Temperature

a. Extruder’s temperature:Extruder’s temperature during printing. The maximum

temperature is 255°C and the hint message will appeared when nozzle temperature
is over 245°C.
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b.

Extruder and Platform:Appropriate temperature of build plate can improve

adhesion and help large models avoid warping.If the machine type is

“FlashForge  Adventurer  3/FlashForge  Adventurer 3  Lite/FlashForge
Dreamer/FlashForge Creator Pro/FlashForge Guider I/ FlashForge Guider Il S
Series/FlashForge Inventor Series/FlashForge Dreamer NX/Flashforge Creator
3/Flashforge Creator Max/FlashForge Adventurer 3C/FlashForge Creator Pro
2/FlashForge Creator Max 27, it displays the
Temperatures of “Left/Right Extruder and Platform”. If the machine type
is“FlashForge Finder/FlashForge Gudier/FlashForge Inventor Il Series”, it only
displays the temperature of “Extruder”.Set temperature according to the filament
type: Set the temperature for left or right extruder and platform. Set 220 to the
extruder temp for ABS,conductive PLA and flexible material printing. Set 50 to
the platform temp for PLA,conductive PLA and flexible material printing ,while
105 for ABS printing. Set (left: 240, right: 220 ) to the extruder temp for
dissolvable Filament printing,Set 105 to the platform temp .If users choose

‘FlashForge Finder/FlashForge Gudier/FlashForge Inventor Il Series’ , users only

need to set up the nozzle temperature according to the material. The nozzle
temperature for PLA is Recommended to be 220°C, Conductive PLA and flexible

material temperature is recommended to set at 230°C.

Adjust the temperature according to the condition in order to get a good print.

4, Retraction

a.

b.

C

Retraction length:Length of filament to be pulled back into nozzle before extruder

traveling or changing, which help prevent from stringing and oozing.

Speed:Speed at which the filament is retracted.
If choosing the machine type of FlashForge Creator Max 2,FlashForge
Dreamer,FlashForge Creator Pro,FlashForge Inventor Series , FlashForge Creator
3. FlashForge Creator Pro 2 or FlashForge Creator Max and using dual-extruder to
print, you can set retraction length and speed of right/left extruder.

Retraction

Right Extruder Length: 1.3mm =

4| ¥

Right Extruder Speed: 30mmi=

| r

Left Extruder Length: 1.3mm

4| r

Left Extruder Speed: 30mmi =

.Only Retract When Crossing Oultine:Used to reduce retraction,but stringing

appears easily on top solid layer.Choose “No” to avoid the issue.Only used for

‘FlashForge Adventurer 3/FlashForge Adventurer 3 Lite/FlashForge Adventurer 3C” at
present.
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E. Perimeter:

Betraction

4k

Retraction Length: 5. Omm

4| F

Speed: 25mm, =

w

Orly Retract When Crozsing Oultine: |Yes

1. Thickness:

a.

Shell Count:Number of paths superimposed for building the shell, more paths make

thicker shell.

b. Maximum Path Overlap:The maximum allowed overlap for perimeters inside a thin

wall.

2. Start Points:

a.

3. Speed:

F. Infill:
1. Gener

a.

b.

Mode:Determines the rule of selecting layer start points.There are three options for

Start Point mode. One is “closest to specific location”, the other is “use random

start points”,the other is “Inner recess point”.
Closest to specific location: All layer start points are aligned as close as possible to
specified XY location.

Use random start points:Layer start points are randomly distributed all over the
model.

Inner recess point:Priority use “inner recess point” as the start point, or use

“closest to specific location” as the start point.
X :X-coordinate where all layer start points are aligned.
Y :Y-coordinate where all layer start points are aligned.

Permit optimize start points:
Allow to adjust start points location when needed, which select a location as start poi

nt except "closest to specific location". Suggest to select "No" when printing upright

reliefs.

Exterior Speed:Percentage of Base Print Speed for printing outer-most perimeter.
Exterior Maximum Speed:To limit the print speed of outer-most perimeter.
Visible Interior Speed:Percentage of Base Print Speed for printing inner perimeters

which is visible when print done.
Invisible Interior Speed:Percentage of Base Print Speed for printing inner

perimeters which is invisible when print done.
al
Top Solid Layers:Number of solid layers on the upper surface of model.

Bottom Solid Layers:Number of solid layers on the under surface of model.
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c. Fill Density: Determines the interior solidity of the model.

d. Fill Pattern:Determines the infill pattern for the interior of model. Hexagon infill is
with the highest strength while line infill is with the shortest print time. Triangle
infill takes slightly more time than line infill, but with more cohesiveness between
Layers,3D Infill is a 3D spiral infill shape,generally used when infilling density is
lower,and it is recommended to turn off combined infill function.

e. Overlap Perimeter:Percentage of extrusion width that will overlap between infill

and perimeters.

f. Vase Mode:When enabled, the interior infill and top solid infill will not printed..
2. Speed

a. Solid Speed: Percentage of Base Print Speed for printing top and bottom solid infill.

b. Sparse Speed: Percentage of Base Print Speed for printing interior infill.

3. Combine Infill
a. Maximum Solid Combine Layers: This option allows to combine the
overlapped infill to speed up printing. After combined, infill will be thicker while
while the thickness of perimeter keeps unchanged. And the top/bottom combine
layer height is not suggested more than 0.2mm.
b. Maximum Sparse Combine Layers: This option allows to combine the overlapped
infill to speed up printing. After combined, infill will be thicker while the
thickness of perimeter keeps unchanged. And the inner combine layer height is not
suggested more than 0.36mm.
c. Combine Area Threshold:When printing area of an layer is smaller than thethreshold
area, Flashprint will not do the combined infilling in this layer, to increase the

printing time of this layer and make sure filament has cooled down before printing

next layer.

4. Strength Infill

a. Interval Layers :At regular intervals layer, force several solid layers to make model

more solid. 0 means not activated.

b. Solid Layers:The number of solid layers force added.
G.Support:
1.General

a. Enable Support: Used to hold the overhangs of model. Allows users to turn on/off
the support option. Support structure can prevent the model from collapsing. If
choosing “Yes”, then both treelike and linear supports are available for setting up. If
choosing “No”, then both treelike and linear supports are unavailable for setting up.

b. Select Extruder: Allows users to select the corresponding extruder. If the machine
type is “FlashForge Dreamer/FlashForge Creator Pro/ FlashForge Inventor

Series/Flashforge Creator 3/Flashforge Creator Max/FlashForge Creator Pro
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C.

2/FlashForge Creator Max 27, it’s available for users toselect extruder. If selecting
“Automatch”, the software will select the extruder automatically depending on the
extruder(s) used. If dual extruders are used, then the right extruder will be used for
supports printing. If the machine type is “FlashForge Finder/Gudier”, it’s
unavailable for users to select extruder.

Adapt soluble support filament: Adjust the preinstalled support slicing parameters
to fit more for printing soluble material supports.

2.Treelike

a.

b.

3.Linear

k.

Speed: Percentage of Base Print Speed for printing treelike support.

Space to Model(X/Y): Determines the minimum horizontal space between model
and supports, which makes supports easier to be removed.

Shell Count: Number of paths superimposed for building treelike support shell.
More paths will generate a thicker skin.

Auto Setup Z Hop : Auto setup Z Hop parameters. Lift the extruder or lower

the platform when the extruder is traveling, to avoid the tree support from being

knocked down by the extruder.

Speed: Percentage of Base Print Speed for printing linear supports.

Space to Model(X/Y): Determines the minimum horizontal space between model
and supports, which makes supports easier to be removed.

Space to Model(Z): Determines the vertical space between model and supports,
which makes supports easier to be removed.

Space to raft(Z): Determines the vertical space between raft and support, which
makes supports easier to remove.

Path Space: Determines the space between adjacent support paths. Smaller space
give finer surface supported, but take more time to print and against to supports

Removing.
Support Thickness:Setting higher thickness to get the more solid support,
while lower thickness result in easy-remove support.
Top Solid Layers: Solid top of linear supports will improve printing quality of
interface between model and supports, but makes supports harder to remove.
Print Qutline:print outline of line support region or not? print
outline to avoid the problem of incomplete region with line support,
otherwise it is better to strip support.
Path Angle: The angle between support printing path and the first layer infill
printing path.
Path Shape:Set path shape of linear support, polyline-shaped path is more beneficial
for support removal while grid-shaped path support structure is more stable.
Path Density: Set support path density, the larger path density makes more stable

support, but longer printing time and more filament consumption as well.
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H. Raft:
General:
a. Enable Raft: Creates a raft below the model which can help with adhesion and

tolerance for non-perfect build plates.Enable to print raft during printing. Raft could

help the model stick to the build plate.

b. Select Extruder: is Allows users to select the corresponding extruder. If the
machine type goes to “FlashForge Dreamer/FlashForge Creator Pro/ FlashForge
Inventor Series/Flashforge Creator 3/Flashforge Creator Max/FlashForge Creator

Pro 2/FlashForge Creator Max 2”, it’s available for users to select extruder, while
the machine type goes to “FlashForge Adventurer 3/FlashForge Adventurer 3
Lite/FlashForge Finder/FlashForge Guider/FlashForge Guider IlI/FlashForge Guider
II' S Series/FlashForge Inventor Il Series/FlashForge Dreamer NX/FlashForge
Adventurer 3C”, it’s unavailable for users to select extruder.

c.  Margin: Raft offset from the outline of the model’s first layer.

d. Space to Model(Z): Determines the vertical space between model and raft, which

makes raft easier to be removed.

e.  Above Raft Maximum Speed:Limits the print speed of the first layer above raft to

make models stick to raft better.
f.  Above Raft Extrusion Ratio: Set the extrusion ratio for the first layer;the higher the

extrusion ratio, the better the first layer and more difficult for the raft to be removed.

Bottom layer:
a. Speed:The higher layer height, the wider extrusion, the slower printing speed shoul
d be chosen, or extruder will not be able to extrusion in time.
b. Layer Height:
Higher bottom layer height will improve adhesion for non-perfect build plates. When b
uild plate temperature is high, the thicker raft also has better insulation.
c. Path Width:width makes it easier to paste raft to the build plate, but the wider path

requires the lower printing speed.
d. Fill Density:The higher filling density, the more stable the raft will paste to build

plate, the longer printing time.
Middle Layers:
a. Layer Height: The thickness of middle raft (transition layers).
b. Layers: The layers of middle raft (transition layers).
c. Speed: The lower printing speed,the easier to paste transition layer on
bottom layer,the more printing time it will take.
Top layers:
a. Layer Height: The thickness of middle raft (transition layers).

b. Cross Angle: The angle between top solid infill paths.
c. Llayers:The layers of top raft,when build plate temperature is higher than 110°C, it is
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recommended to print more layers to improve the thermal insulation.
d. Speed:The lower speed, the better surface finish the top raft will have, the longer
printing time.
I. Additions:
1.Pre-extrusion

a. Enable Pre-extrusion: Print an extra extrusion path before model printing.
b.  Margin: Determines the spacing between pre-extrusion path and the outline
of the model’s first layer.

c.  Path Length: Determines the length of pre-extrusion path.

d. Speed: The printing speed of pre-extrusion.
2.wall

a. Enable Wall: Creates a wall around the model to scrape oozing from the idle extruder.
It's suggested to enable in dual extrusion printing.
b. Shell Count: TNumber of paths superimposed for building wall. More paths will
generate a higher strength wall but take more print time.
c. Margin: Determines the spacing between model and wall.

d. Speed: Speed at which the wall is printed.
3.Brim
a. Enable brim: Expand the outline of model’ s bottom layers to a Brim which helps
anchor the edges of the model to the plate to avoid warping.
b. Select extruder: To select left extruder , right or automatch extruder if the machine
type is
“ FlashForge Dreamer/ FlashForge Creator Pro/ FlashForge Inventor Series/Flashforge
Creator 3/Flashforge Creator Max/FlashForge Creator Pro 2/FlashForge Creator Max 2”;
If the machine type is “FlashForge Adventurer 3/FlashForge Adventurer 3
Lite/FlashForge Finder/FlashForge Guider/FlashForge Guider Il/FlashForge Guider Il S
Series/FlashForge Inventor Il Series/FlashForge Dreamer NX/FlashForge Adventurer
3C” there is no need to set extruder, the default extruder is right.
¢. Margin: The width of Brim, the wider brim is, the more stable it will be, the longer it
will take.
d. Brim layers:The more layer of brim the better anchoring the edges of the model, the
harder to remove.
e. Speed:The speed of brim printing.
f. Don't generate Brim inside holes: Brim won’t be generated inside holes, to avoid the
difficulty of removing.
4. Wiping Tower
a. Speed:Speed at which the Wiping Tower is printed.
J.Cooling
1.Decelerate/Delay For Filament Cooling
a. Deceleration Area Threshold:When the print area of one layer is less than the area
threshold, printer will slow down to ensure enough time for filament cooling.

b. Delay Area Threshold:When the print area of one layer is less than the area
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threshold, printer will delay printing to ensure enough time for filament cooling.
Printer doesn’t delay printing for filament cooling if the Delay Area Threshold is
0.

¢.  Maximum Delay Time:The maximum delay time for filament cooling.

Deceleratef/Telay For Filament Cooling

Deceleration hrea Threshold: SOmm”2 =

13

Delay Ares Threshold: Omm™Z

4

13

Maximum Delay Time: 1.5=

4

2. Cooling Fan Controls
a. Cooling Fan Controls:Set up the time to turn on the cooling fan.Fan Status:
Including “Always On”, “Always Off”, “ON(when raft bottom printed)”,
“ON(when to pre-set height)”, “ON(while printing raft top)which only apply to
“FlashForge Adventurer 3/FlashForge Adventurer 3 Lite/FlashForge Creator
Pro/FlashForge Dreamer/FlashForge Guider IlI/FlashForge Guider Il S
Series/FlashForge Inventor Series/Flashforge Creator 3/Flashforge Creator
Max/FlashForge Adventurer 3C/FlashForge Creator Pro 2/FlashForge Creator Max
2” at present.
b.  The Pre-set Fan On Height: Turn on the cooling fan when to specific height.
c.  Back Fan Status: Set the status of cooling fan on the printer backboard.Including
“Always On” and “Always Off’. Only apply to FlashForge Adventurer
3/FlashForge Adventurer 3 Lite/FlashForge Adventurer 3C and FlashForge Guider

II S Series at present.

_i Additions i Cooling | Advanced ! Others -I

Cooling Fan Controls

Cooling Fan Status: ||:IH (when to pre—zet ] v|

The Pre—set Fan On Height: 0. 00mm =

Back Fan Status: lﬁ.lways On Vl

3. Rest temperature at heights
a .Exturder: Reset the temperature of extruder once reach to specific height. Edit the
height value which needed to reset temperature, please don’t over the model
height.(When printing dual model file, please set left and right extruders)As shown
below:

Beset Temperature At Heights

Extruder: | s J I Edit |

Step: click “edit” button,enter into edit page(as shown below), edit reset height and
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temperature value, click “+” button to start setting,the added value will showed in
“delete reset height” list.

4 Reset Temperature At Heights ||
#dd Reszet Height: 10, Omm |5 2007 |2 +
Remowe Reset Height: | v| =
0k || Cancel |

b.Platform: Reset the temperature of platform once reach to specific height. Edit the
height value which needed to reset temperature, please don’t over the model
height.Only  used for“FlashForge Dreamer/FlashForge Creator Pro/FlashForge Guider Il/
FlashForge Guider Il S Series/FlashForge Inventor Series/FlashForge Dreamer
NX/FlashForge Creator 3/FlashForge Creator Max/FlashForge Creator Pro 2/FlashForge
Creator Max 2” at present,As shown below:

FLat form: =] | Edit |

Step: click “edit” button,enter into edit page(as shown below), edit reset height and

[

temperature value, click “+” button to start setting,the added value will showed in
“delete reset height” list.

K.Advanced
1.Stepper Motor Voltage(Usually keep default)

a. X-Axis: Voltage parameter of X-axis stepper motor. The bigger the value is, the
more powerful X-axis stepper motor is, but the more heater will produce.

b. Y-Axis: Voltage parameter of Y-axis stepper motor. The bigger the value is, the
more powerful Y-axis stepper motor is, but the more heater will produce.

c. Z-Axis: Voltage parameter of Z-axis stepper motor. The bigger the value is, the
more powerful Z-axis stepper motor is, but the more heater will produce.

d. A-Axis: Voltage parameter of A-axis stepper motor. The bigger the value is, the
more powerful A-axis stepper motor is, but the more heater will produce.

e. B-Axis: Voltage parameter of B-axis stepper motor. The bigger the value is, the

more powerful B-axis stepper motor is, but the more heater will produce.
2.0thers
Extrusion Ratio: Extrusion multiplier for all extrusion movements.
b. Path Width: The width of extrusion path. The default value is 0.4mm which equals
the diameter of nozzle
c. Path Resolution: Determines the extrusion path resolution when model is

over-detailed. The bigger the value is, the lower path coordinate resolution is.
However, the extrusion precision will be higher.
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d.  First Layer Extrusion Ratio: Extrusion multiplier for the first layer extrusion
movement.
3.Bridge
a. Enable Bridge:Optimized effect of tool path and shorten the span of tool path to
improve the effect of floating printing.
b. Bridge Area Threshold:When the floating area is less than the specified threshold
area,bridge function is not available.

c. Speed:The ratio of the bridge print speed to the reference speed.

Bridze

Enable Bridge: Yes -

Bridge hrea Threshold: 15mm”2

4| ¥

4| ¥

Speed: 0%

L.Others

1. Pause At Heights

a. Pause At Heights: Pause printing automatically when to specific heights.Users can
add one or more specific height values(no higher than the model height). It displays

as follows

| Layers I Shells I Infill I Speed I Temperature | Others [

Pasd ke Haighte: | 10. Omm =] | Edit |

Steps: Click the [Edit] button, and a box will pop up(See graphic below). Then add the value,
click [+] for confirmation, and the value will show in the list of [Delete Value]. If deletion is
required, select the specific value on the list and click [-] for confirmation. Click [OK] to finish

and exit these steps.

4 Pause At Heights e S

Add Pauze Height: 10, Omm 5 +
FKemowe Fause Height: | A £

| & || Cancel |

b. Edit Pause At Heights : Add or remove the Pause Heights.
2. Dimensional Adjustment

a. Enable Adjustments: Adjust extrusion paths to compensate printing error.
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b.

C.

d.

External Compensation: Adjust the model’s outer diameter, set positive to enlarge
dimension and set negative to shrink dimension.

Internal Compensation: Adjust the model’s inner diameter, set positive to enlarge
dimension and set negative to shrink dimension.
Z Compensation:Adjust the model’s print height,set positive to enlarge height and set
negative to reduce height.

Dimen=zieonal Adjustments

Enable Adjustments: Ha -
External Compenszation: 0O.00mm 3
Internal Compenszation: 0O.10mm =
Z Compensation: 0. 00% =

3.Sequential Printing

a.

Enable Sequential Printing:Print one model completely and then print the next one.lt
can reduce the stringing caused by the nozzle moving back and forth between models.

Right Nozzle Margin X:Maximum distance from the nozzle center to the extruder
border.In order to avoid the collision between the extruder and models,model spacing
must be greater than this distance.If raft or brim is enabled,the model spacing needs to
be additionally increased by the maximum width of raft or brim.

Right Nozzle Margin Y:Maximum distance from the nozzle center to the extruder
border.In order to avoid the collision between the extruder and models,model spacing
must be greater than this distance.If raft or brim is enabled,the model spacing needs to
be additionally increased by the maximum width of raft or brim.

Left Nozzle Margin X:Maximum distance from the nozzle center to the extruder
border.In order to avoid the collision between the extruder and models,model spacing
must be greater than this distance.If raft or brim is enabled,the model spacing needs to
be additionally increased by the maximum width of raft or brim.

Left Nozzle Margin Y:Maximum distance from the nozzle center to the extruder
border.In order to avoid the collision between the extruder and models,model spacing
must be greater than this distance.If raft or brim is enabled,the model spacing needs to
be additionally increased by the maximum width of raft or brim.

Gantry Height: The minimum distance from the bottom of the nozzle to the Y-axis
screw.In order to avoid the collision between the gantry and models,only one model is

allowed to exceed this height.
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Sequential Printing

Enable Sequential Frinting: |Ho -

Bight Hozrzle Margzin X |54 90mm
Bight Hozrzle Margzin Y@ |52 45mm
Left Hozzle Margin X: |71 S0mm
Left Hozzle Margin T: |52 45mm

Gantry Height: 11.1Tmm

4.7 Hop
a. Z Hop Mode: Lift the extruder or lower the platform when traveling to avoid
the extruder from bumping into the model.
b. Z Hop Height: The height at which the extruder is lifted or the platform is lowered when

the extruder is traveling.

¢. Z Hop Minimum distance: When the traveling distance is less than the specified value,
the Z Hop is not performed.

Z Hop
Z Hop Mode: Mways Dizable -
Z Hop Height: 0. 20mm =

Lilg

Z Hop Minimam Distance: 1. 00mm

M . Save as new:Allows users to save the model as a new file after parameter modification.
How to do?
After getting all the required parameters modified, click [Save as new], then a dialogue box will
pop up. Users need to enter the file name into the box, then click [OK]. Click the drop-down
menu of [Select Profile], the new added scheme can be found in the list.
N. Remove
Allows the users to delete the added scheme(s). Select one of the added schemes, click [Remove]
and a dialogue box will pop up for confirmation. Click [Yes] to remove it or click [No] to cancel
the current operation.
O. Restore Default: Allows users to restore to the default settings.
P. Save Configuration: Allows users to save the present configuration.
R.port/Export Profile:After modifying the required parameters according to the user's needs, save
the current slice parameter scheme as a local file for subsequent use.
Action: When the profile needs to be exported, click the 'Export Profile' button to save the current
slice parameter scheme as a local "fprofile" format file;Click the 'Import Profile' button when you
need to import a profile:Import the .fprofile-formatted slice parameter profile into the profile
table, and there is an additional option in the 'Select Profile' list (the new scenario is related to the
mode selected when the profile is exported, only added to the 'Select Profile' list for the
corresponding model)
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3.8.3.4 FDM 3D Printer Print Gcode File

a. Slice
After finishing slicing, it will load into the generated Gcode file automatically if you select Preview
option when slicing, or need you manually load into it and then go to preview interface. In the
preview interface, there is a vertical scroll bar which shows each layer of the model and you can find
Estimated Material Right . Slice Parameters . Estimated Print Time and Weight Estimation it
costs on the top right corner. Then click send Gcode button on the same location, the machine
starts to print while click Back button to exit from Preview mode.
b. Weight Estimation
€ Material length: The material length required to print the model.
€ Material Type: FlashPrint 3.19.0 support material weight estimation. When you select
"Custom Material", you can manually change the "Material Density".
€ Material Density: The material density, which is corresponding to material type.
€ Weight Estimation: Filament weight is estimated from the length and density of the

filament.

& FlashPrint - C/Use

Fle Edit Print View Tools Help

166 G
Layers == ——

\i Send GCode Back

FlashForge Dreamer

3.8.3.5 Pause or Terminate Printing

Once printing starts, click the machine icon on the bottom right corner of the software interface
and it will show the process status in a frame. Pause and Stop button displayed at the bottom of
the current model's status bar. Click Pause button to pause printing and then click Continue
button to resume it. Click Stop button to cancel this printing task and you need to restart
this print task if you want to print it again.

Note: Please DO NOT click Pause button unless necessary, for it will affect printing result.
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3.9 Printer Operations

3.9.1 Connect / Disconnect

The computer can be connected to multiple printers at the same time in two ways:1.Auto connection;
2.Wi-Fi/ Ethernet connection. The machine icon on the bottom right corner of the software interface
shows a broken chain pattern means disconnected, while shows a unbroken one means

connected,and tap icon to hide/show the status bar of all printer connections.
3.9.1.1 Connect

A. Auto Connection

a. Find USB ports on the right-side of machine and computer, plug in and connect.

b. Open Flashprint software and turn on the printer.

c. Click Print -> Connect Machine menu, then select Automatic in the Connection Mode
option and select machine you want to connect in Select Machine option. If you can
not find your machine, click Rescan button to scan your machine and select it. Finally
click Connect button to connect to the printer. If you still can not find your machine
after rescan, which means you haven’t installed the driver in the software. You have to
install the driver manually, please refer to the Chapter 2.8.3.1. Normally, driver shall be
installed automatically along with software.

The "Automatic" connection mode scans and displays all available machines, including
Wi-Fi connections and USB cable connections.
B. WIFI connection

a. Via wireless network
1. Switch on the printer, and make the WIFI available by clicking the menu Tools ->Set

up->WIFI->WIFI ON.

2. Turn on the WIFI and then connect the computer to the network whose name is the
same as SSID.(It is the printer’s default network without password if no settings have
been made. )

3. Open your browser and enter the IP address 10.10.100.254 in the Address Bar. Then

enter in admin as the account and password . (The above-mentioned IP address
/Account /Password are default when the setting haven’t been changed)
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@ami th 7| English| B 3%

FLASHFORGE

MID

System Info Smmcle D v
Work Mode WiFi Work Mode

_ S
STA Setting == i
AP Setting e o
COM Socket MACAdess  DBBIMCFIADS

STA Mode
Account = s
Firmware e —————————
IP Address

HRSAIR admin

MAC Address

4. Enter the WIFI setting panel, select “AP+STA mode” for Dreamer, select “AP” or “STA”

mode for Finder, then click [OK]. Note: Don’t click [Restart].
(Note: If users only choose STA mode, it has the potential risk that Dreamer will fails
WIFI connection forever once STA settings crash.)

A 6§ W #% H 3| English| B A&

Select Mode

System Info

Work Mode AP mode: module work as Wifi router, allow laptop or mobile to
connect it, allow 2 device connect at same time, then the settings in

STA Setting AP setting will work.

AP Setting STA mode: module work as wifi device like mobile or laptop, then the
settings in STA setting will work.

COM Socket
AP+STA mode: both of AP and STA work.

Account

Firmware SR

MRSHIR: admin

Save

5. Click STA Setting, and then click Scan button and choose a commonly used network.
Type in password, save it, and then click Reboot to the printer.
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(A §6 Wl 3% $ 37| English| A &%

Network Name {SSID) -
Note: case sensitive I8 B VVIFI250 Sl
System Info —————
Encryption Method M
Work Mode S e EEE
STA Setting Password
AP Setting W Show passwords
Obtain an |P address automatically
COM Socket
IP Address
Account
Subnet Mask
Firmware
Gateway Address
R’ admin

DNS Server Address

6. 5 seconds after the reboot, choose disconnect and try to connect WIFI again. Open
FlashPrint, click the menu Print->Connect to select WIFI connection, and then
enter the network IP address (same as the IP showed on the touchscreen) in the IP
port option. Finally click connect to complete it. After this, you do not need to
connect WIFI in the future if no WIFI setting is changed. If you want to change WIFI
setting, please try the same way.

b. Via wireless source set by the printer

1. Switch on the printer, and make the WIFI available by clicking the menu Tools ->Set
up->WIFI->WIFI ON”.

2. Turn on the WIFI and then connect the computer to the network whose name is the
same as SSID.(It is the printer’s default network without password if no settings have
been made. )

3. menu Print -> Connect, and select Wi-Fi in the Connection Mode bar. Type in
10.10.100.254:8899 in the IP Address, Port bar, then click Connect button to
complete it.

Note: One printer could only have one connection. If printer is operating by another
process, connections should be switched off firstly and try to connect again. If AP mode
is chosen, the computer will be unable to go online by WIFI.

3.9.1.2 Disconnect from the printer

When one or more printers are connected, select any printer and tap the "disconnect"button in
the status bar of this printer to disconnect the computer from this printerTap the menu bar
"Print-> Disconnect All Connections" to disconnect the computer fromall printers.

3.9.1.3 Set As Current
When the computer is connected to multiple printers at the same time,tap the "set as current"
button in the printer status bar to Switch the operation interface to the corresponding interface
of the printer you chose.
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3.9.1.4 Modify Printer Name
In the status bar of connected printer, tap the button to the right of printer name,the dialog box
would pop up for modifying the name.Tap "OK" after modifying the name, and the printer name
is successfully modified;Tap cancel if you don’t modify the printer name.

0 On Board Preferences ﬂ

Machine Hame (32 Bytes): a=d

| ok || Cancal

3.9.2 Control Panel

After connection between software and 3D printer is built, click Tools->Control Panel menu to open
the control pane. Following operations are available in the control panel to control the printer.

The control panels of different machine types are different. The control panel of ‘FlashForge
Adventurer 3/FlashForge Adventurer 3 Lite/FlashForge Dreamer/FlashForge Creator Pro/FlashForge
Inventor Series/FlashForge Inventor |l Series/FlashForge Dreamer NX/Flashforge Creator
Max/FlashForge Adventurer 3C/FlashForge Creator Pro 2/FlashForge Creator Max 2’ shows in the
‘control panel 1, while that of ‘Flashforge Finder’ shows in the ‘control panel 2’,while that of
‘FlashForge Guider/FlashForge Guider ll/FlashForge Guider II S Series’ shows in the ‘control panel 3’.
While that of ‘Flashforge Creator3 ‘showsinthe ‘control panel 4’ . (this function is only available to
FDM 3D printer)

Control Panel o
g —— —
Homing
Jog Contrels Right Extruder Left Extruder
Jog Mode =
- . Moter Speed GO 5 S
Extrude Duration [55 ']
2 TE
Y e Wabar Condrals [ PR ] [ Reverse ] [ Stop ]
¥ T 0.0 Center T
7 0.0 Temperature Controls
it 0 2000 mnfmin O Left Terget 0 Lifi Civient a0
T Speed * D &o0 mmfmin O FPlatform Target a B Flatform Current 27
Temperature Flot
Limit Switch Cooling Fan Controls
¥ Maximun Switch: ot Tirggered Tunon | [ Twnaft |
T Maximum Switeh: Tirggered Stepper Motor Controls
T Minimun Switeh: Hot Tirggared Bnable | [ Disible |
hen Extruder and Platform are both need to heat up, Extruder will WOT heat up
1ED Color I until Flatform reach the giwven temperature.

(Control panel 1)
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€ Control Panel

Homing

Jog Controls

Tog Made
Contimuous Jog ']
St

[Make current position zere
A Speed [ 2000 mmfmin
Zoted [ 00 W
Limit Switch Stepper Motor Controls
¥ Maximum Switch: Wot Trigzered [ i ] [ P ]

Enatle Disable

T Maximum Switch! Hot Triggered

Z Maximum Switch: Tri d
HERT Servo Controls

Filament Detect

Extruder Controls

Motor Speed (REM) 5.00 &

Extrude Duration 5= -]

Witor Conteels [ Porwswra || Beverse |[  stes |

Tenperature Controls

[0 Extruder Target i} W Extruder Cwrrent

a |

Temperature Flot

[ Turn on ] [ Twrn off ]
Filament Status: Filament Loaded — - -
When Extruder and Platform are both need to heat up, Extruder will HOT heat up
1ED Calor WP e Rl ke e
(Control panel 2)
Control Panel
Homing
Jog Controls Extruder Controls
Jog Made Motor Speed (REM) 5.00 2
Eantinuinselioe -] Extrude Duration 5= -
|
%00 Motor Controls [ Powerd | [ Beverse || st | |
St
Temperature Controls
[ Extruder Targzet o W Extruder Current 2
[Makse current positien zero
Temperature Flot
XY Spead [ 2000 omfmin 900
T Spesd i 800 mmfnin 250
200
e EE e
150
¥ Maximan Switeh: Hot Triggered [ Eneble || mDisable |
100
T Maximum Switch: Wot Triggered Servo Controls 50
T Maximun Switch! Trigeersd [ rwanon || Twnosr | o
When Extruder and Platform are both need to heat up, Extruder will HOT heat up
LED Color until Flatform reach the given temperature.

(Control panel 3)
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% Control Panel { ekl B

Taeatiozstrols Right Extruder | Left Extruder |
e Toz Mode =]
Right Extruder | Left Extruder s Moter Speed (EFM) 500 -
[continuons Tog "] | Ertruade Daretion 5= ~]
 Bight —20.4 Wi Fannts [ Forward | [ Beverss || G ]
- ¥ Left 20.4 Center ¥
oF - Temperature Controls
Bl Rith Tarest 220 B Richt Current 89
O Left Target 220 Lt Cirvent 8a |
e
[ ) O Platform Target 50 B Platform Current |47
Y Speed [} 2000 nmfnin Temperaturs Flot
300 74
I Speed {1 800 nminin i
250
Filanent Detect Cosling Fen Contrels
200
[ twmen J[ Twnesr | im
: - 100
Filanent Status:  Filament Unoaded Stepper Motor Controls
50
[ Enade || misabie |
o
When Extruder and Flatforn ave bath nesd to heat up, Extruder will HOT heat up
Turn en LED ] [ Turn off LED ] until Flatform reach the given temperature.

(Control panel 4)

A. Jog Controls
a. Jog Mode:
You could set the distance the extruder or the platform moves by a single jog click time.

b. Direction Buttons:
These six blue-arrow buttons are set to control the movements on X/Y/Z directions. Click the
direction buttons of x-axes and y-axes to control the horizontal movements of the extruder. Click
the direction buttons of z-axes to control the vertical movements of the platform. Click X- button to
make the extruder move to the left; click X+ button to make the extruder move to the right. Click Y-
button to make the extruder move forward; click Y+ button to make the extruder move backward.
Click Z- button to make the platform move upward; click Z+ button to make the platform move
downward.The distance of movement will be showed in the X/Y/Z value bar.

c. Stop Button:
Click this button to terminate current movement.

d. Coordinate frame:

It displays the coordinated positions of extruder and platform.

e. Make current position zero button:
Click this button to set the current position of the extruder and platform as the origin of
coordinates.

f. Center X/Y/Z button:

Click these buttons to return the extruder or platform to the origin of coordinates automatically.

g. X/Y/Z Speed sliding bar:
Set the moving speed of the extruder and platform by sliding the speed sliding bar.

B. Limit Switch
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In order to protect the 3D printer, there are three limit switches on X/Y/Z axes used to control the
movement limited position. they have the following two statuses:

a. Open Status:
If the extruder or platform has not reached to the limit position of X/Y/Z direction, the switch

won't be triggered and its status is Open.

b. Triggered Status:
If the extruder or the build plate moves to the maximum position, the maximum or the minimum
limit switch of X/Y/Z axis will be triggered and shows “Triggered” according different machine

types.

C. Fan Controls
Click Open button to turn on the cooling the fan, while Close button to turn it off.

D. Stepper Motor Control
It is used to control the stepper motor. Click Open button to lock the stepper motor and users can not
adjust the position of extruder and platform manually, while Close button to unlock it and users can

do manual adjustment on extruder and platform.

E. LED Color
The printer has a built-in LED, Click LED Color button to change its color built in the printer.

F. Extruder Setting

In the interface of extruder setting, you could feed in or withdraw the filament from the left/right
extruder. By changing the value of “Motor Speed (RPM)”, you could control the speed of feeding in
and withdrawing filament. In addition, you could control the time of these actions through changing
the value of “Extrude duration”. Generally, we suggest you set the extrude duration as 60s.

Before feeding in or withdrawing the filament, the extruder should reach target temperature to melt
the filament before you click Forward / Reverse button to start these operations. For ABS filament,
target temperature of extruder is 220°C; for PLA filament, target temperature of extruder is 200°C.
for dissolvable Filament filament, target temperature of extruder is 240°C . Click Stop button to stop

feeding in or withdrawing filaments .

G. Temperature Control

Type in the target temperature in the left blank and click Apply button to heat the extruder or
platform. The printer starts to heat the extruder or the platform, and you will see the actual
temperature the extruder or platform has reached on the right and a temperature changing table
with 3 different color curve line below.

Note: The printer will heat platform firstly to reach target temperature and then heat extruders when
both are needed to heat.

H. Filament Detection
To detect whether the filament is loaded in Finder.

L. Servo Control
To control the servo’s on-off.
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3.9.3 Firmware Upgrade

Only Dreamer/Dreamer NX/Inventor/Creator Max/Creator Pro 2/Creator Max 2 support the function
of firmware updating.Finder doesn’t display ‘firmware updating’ by default, and ‘firmware updating’
displays when using the old FinderThe software will check and download updates automatically when
users open it, and remind users to upgrade to new version if available. Ways to install firmware as
follows,Finder 3D printer must connect computer with USB cable before update firmware(this function is
only available to FDM 3D printer):

A. Disconnect the computer and printer, or Click Tools -> Update Firmware menu and select
Disconnect option,
B. Select your machine type and corresponding firmware in the popped up dialog and then click OK
to upgrade. If the machine is idle, it will start to upgrade to new firmware.

4 Update Firmware @
Machine Type: [FlashForge Dreamer "|
Select Firmware: |dreamer_2.2.2l:ll41222 "J

i
Change Logs -

v2.2.20141222
1. Fix a bug that 1f machine use G2 module user can not use
S0 card mormally (but fhen WIFI twrn on, 5D card dizabled)

2.2 20141211
1. Fix a bug that can not find dewice by ushk after dizconmect
2. Add support for G2 wifi module

Li1lm a

0k || Cencel

3.9.4 On Board Preferences

When the printer has been connected, click Tools-> On Board Preferences menu to review the
configuration of mother board including Machine Name, and Extruder count etc. When choosing extruder
count as 2, Extruders Distance option is available. Users can modify the X/Y distance between the
extruders as need.The X/Y distance refers to the distance of X or Y directions between the two extruders.|f
it is ‘FlashForge Adventurer 3/FlashForge Adventurer 3 Lite/FlashForge Finder/FlashForge
Guider/FlashForge Guider IlI/FlashForge Guider Il S Series/FlashForge Inventor Il Series/FlashForge
Dreamer NX/FlashForge Adventurer 3C’, the content only includes the name of the machine.(this function is
only available to FDM 3D printer)

@- On Board Preferences S|
Machine Hame (32 Bytes): FlashFrint 3d
Extruder Distance: ¥ 34 Omm =, T 0 0Omm =

| Ok || Cancel
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3.9.5 Reset Motherboard Completely

At present, only Creator Pro contains this function. Use USB cable to connect the printer, and click ok to

reset the motherboard parameter.
4 Reset Motherboard Completely )

Select Serial: l':':lfﬂl 'I | Rescan J

o [ ]

3.9.6 Machine Information

When the printer has been connected, click Tools->Machine Information menu to review the
information about the machine, including MACHINE TYPE, MACHINE NAME, FIRMWARE VERSION, etc.

(this function is only available to FDM 3D printer)
3.9.7 Driver Installation

A. Open the root directory of the software. (e.g. C:\Program Files\flashforge\FlashPrint)

B. Open the driver folder which in the root directory and find the driver. There are two driver
installation packages, please install one of them according to your computer system. For
64bit edition, please install dpinst_amd64.exe file; while for 32bit edition, please install
dpinst_x86.exe file.

(this function is only available to FDM 3D printer)

3.9.8 Multi-Machine Control

Click the <Multi-Machine Control> under the <Tool> to enter the interface:
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L 4

*

L 2R 2R 2R 2% 2% 2R 4

&Multi-M&chine Contro - =)
Send Code Continue | [ Pause sbort | [Disconnect love To

Ungronped | Groupl

Select ALl

Connect the machine: same as the <Print— Connect Machine> function, the connected machine
will display in the group.

Send the GCode: send gcode to the same types of this machine, at most five machines at one time
with the rest queuing for sending gcode; the other types of machine are not allowed to send
gcode.

Continue: send the <continue printing> instruction to all selected printers in suspend

Pause: send the <pause printing> instruction to all selected printers in printing

Suspend: send the <suspend printing> instruction to all selected printers in printing

Disconnect: disconnect all selected printers

Remove: remove all selected printers to the designated group or a new group

Delete: delete this group, the printers in this group will be automatically moved to [ungrouped]
Select All: select all printers in the group

3.10 Others

3.10.1 Preferences

Click File-> Preferences menu to select the interface language and etc.

0 Preferences L ‘ X 0 Preferences . s |
General Frint General Frint
Langnage: futo layout newly—imported model:
Font Size: Preferred Extruder:
Check for Updates after start up: |Yes - Printing Windew Type: |
[ o || canea | | [ o || cema |
1. General
A. Language
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So far this software supports English, Japanese, Simplified Chinese ,Traditional Chinese,French,
German,Arabic,Spanish,Czech,Turkish,Portuguese,Polish,Korean,Russian.

B. Check for Update after Startup
Select Yes option to command the software auto-check updates after starting up it. The software
will remind you to update to new version when it is available after checking.

C.Font Size
Use to setting the font size of the software.Large,Middle and Small front mode to choose. If 'font
size' chose 'large’, the software font is large font mode.If you choose middle mode, the front of
software is middle.otherwise is small font mode. The default font size is small font size.

2. Print

D.Auto-layout newly-imported model
To setup the model’s position and posture. If you select [Yes], the model will be on the platform
and auto-centered when you load the model. If you select [No], the model will maintain its initial
position and posture when you load the model.

E. Expert Mode
Expert Mode grants the users more freedom of parameter edition. There are two modes are available
for users, one is “Basic Mode” and the other is “Expert Mode”.

F. Performence extruder
It is the setting to save the choice of performence extruder, which is only for Flashforge Creator
3,Flashforge Creator Max,Flashforge Creator Pro ,FlashForge Creator Pro 2,FlashForge Creator Max
2 and Flashforge Dreamer. According to 3D printer condition and usage habit, user can set the
performence extrude. Extruder choosing will not needed before silcing. (this function is only available to
FDM 3D printer)

3.10.2 First run wizard

An explanatory menu pops up the first time you open Flashprint. Click Continue to learn more about
the features, or close the menu if you're already familiar with the features.

You can go to Help -> First time user guide to re-open the menu when you need to learn the features
Later.
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3.10.3 Help Contents

Click Help-> Help Contents menu to be directed to online user manual.

3.10.4 Feedback

Click Help->Feedback, users can feedback suggestions and problem:s.

0 Feedback

[itle
@ Suggestion

Faedback Content

(1 Problem

Attachments:

Tonr Email:

|:| Send log filaes

Submit

3.10.5 Check for Updates

A. Automatic Update

Refer to 2.9.1 to set auto update.Click button of skip this version, you can skip the update.

B. Manual Update

Click Help-> Check for Updates menu to check new version of software online. If there is an
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updated version of the software to be detected, it will pop up a new version of update dairy, according
to their own needs users can download and install the updated version or close the prompt .

0 FlashPrint w

- 3
I:el A new wersion of FlashPrint is awailable, would you like to download?
b

R ]

Change Logs —

The upgrade=z in FlashPrint-3 13.0

Suppert 3mf format model loading and sawing

#dd setting function of performance extrude

#dd =lice parameter setting of conductible FLA and =oft filament
#dd update diary when the new wersionm of FlashPrint is awailable
Reduce defanlt print speed to increase printing gquality

Fixed the bug that some model with line-support fail slice

s st AT

Fixed the bug that there haz space in z—direction between model and
line—szupport when using dissolwable filament

G Optimizated model repailr code to decrease the repairing time of big
madel

1.1~1.2 to install the software.

3.10.6 Software Information

Click Help-> About FlashPrint menu to review information about the software, including software

version and copyrights, update log etc.

FlashPrint ,., 5 5.

S20153-2020 FlashForge All rights reserwved.

www, flashforze. com

Changze Togs
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