G4 dwell option, not working

BEESOFT is the software that controls your BEETHEFIRST and BEEINSCHOOL line of 3D printers
Post Reply
User avatar
diego.cuevas
Posts: 5
Joined: 30 Dec 2019, 10:03

G4 dwell option, not working

Post by diego.cuevas » 30 Dec 2019, 10:15

Hello,
I'm doing my own g-code for the BEETHEFIRST. Everything works perfectly except one thing: I'm trying to make the machine 'wait' at certain points using G4 but it is not stopping. Is it my g-code that is wrong, or is it something going on the firmware?
Example of what I'm trying to do, making the machine 'dwell' 2 seconds:

G1 X-50.0 Y-50.0 Z0.3 F3000
G1 X-50.0 Y50.0 Z0.3 F500 E20
G92 E
G4 P2000
G1 X0.0 Y-50.0 Z0.3 F3000
G1 X0.0 Y50.0 Z0.3 F500 E20

Any idea?

tgala
Posts: 87
Joined: 25 Aug 2015, 14:56

Re: G4 dwell option, not working

Post by tgala » 02 Jan 2020, 14:52

Hi @diego.cuevas,
I don't think G4 is implemented on the firmware. You can check the firmware here: https://github.com/beeverycreative/beethefirst-firmware (there is also a LibreOffice Calc file with the list of G-Codes implemented).

Depending on what you're wishing to do, you can insert a "pause" G-Code (that must me resumed manually via the software or G-Code console).

There is also an hack that works with BTF's firmware which I'll try to explain: the BTF firmware reads the G-Code some number of lines ahead of what is being executed at a time; commands that imply a movement of axes are executed sequentially, but some commands are executed as soon as they are seen by the firmware (one of this commands is the M300 - beep). Since this lookahead is a limited buffer, one can trigger some kind of temporary "pause" by filling this buffer with M300 commands in a way that the firmware finishes executing the movement commands while executing the M300.

I've used this technique a few years ago and details aren't clear but I suggest starting with something like 20 lines of "M300 S1000 P1000" to see how it works.

By the way, what are you planning to achieve with this pause?

Cheers!

User avatar
diego.cuevas
Posts: 5
Joined: 30 Dec 2019, 10:03

Re: G4 dwell option, not working

Post by diego.cuevas » 04 Jan 2020, 10:09

Hello @tgala ,
Thanks for the tip. Your comment was very instructive. I tried the strategy of the M300. With 8 lines of 'BEEP' the machine was confused enough to stop for a while. But then I got oozing issues... it seems that it is better not to 'dwell' the machine and work with the geometry for my porpouse.
I'm trying to 3d print a linear structure in the air. Attached picture.
Thanks for your help!
Diego
Attachments
01.jpg
01.jpg (2.19 MiB) Viewed 862 times

tgala
Posts: 87
Joined: 25 Aug 2015, 14:56

Re: G4 dwell option, not working

Post by tgala » 06 Jan 2020, 10:18

Awesome!
I think you can play with extrusion speed and cooling to improve that structure. It seems like your filament might be too hot to hold the structure properly, if you let it cool (use the blower fan) you'll probably get better results.

User avatar
diego.cuevas
Posts: 5
Joined: 30 Dec 2019, 10:03

Re: G4 dwell option, not working

Post by diego.cuevas » 07 Jan 2020, 16:01

Well, the fan was already ON, but as it is 1mm. noozle it takes its time to harden :)
I had to 'play' with the geometry till something started 'to work'. Finally I got a larger object: https://www.instagram.com/diegocuevascnc/?hl=en
Thanks for the tip!

Post Reply