Forum under maintenance. Please contact us at customer_service@beeverycreative.com

Steppers stop working

The versatility of an entry-level 3D printer, engineered to last.
By BEEVERYCREATIVE and Hello 3D Printing World
Post Reply
AndrewPayton
Posts:1
Joined:03 Sep 2020, 11:51
Steppers stop working

Post by AndrewPayton » 03 Sep 2020, 12:01

Hello !

Just a few days ago my HelloBee Prusa 3D-printer was working like a charm but now suddenly the steppers for extruders and x- y- and z-axis are no longer responding to commands.. When the printer is turned on it gives out this high pitched noise which is most likely coming from the steppers as they are not moving at all. The steppers are warm and preventing the manual movement of the print head which indicates that they are receiving power but when commanded to move via LCD panel they won't move or make any kind of effort to do so. I have double, even triple checked the wiring.

Heating nozzle and the bed works normally as it should and the fans are spinning normally. As so, the problem should not be with the PSU as heating components require the higher voltage from PSU, right? The Arduino board is most likely not busted either since it can still control the other components besides stepper motors. This leaves the stepper motor drivers as my main suspects but I have no idea what could have happened with them other than possible frying which seems very unlikely.

Any ideas/help will be appreciated!

DomingosRodrigues
Posts:197
Joined:12 Dec 2017, 11:44

Re: Steppers stop working

Post by DomingosRodrigues » 03 Sep 2020, 12:19

Hello Andrew,

By what you described it appears that either the pins of the Motherboard that control the axis or the stepper drivers have been damaged, considering that your extruder stepper drivers are working, in order to test this do the following:

:!: Be very careful with the drivers orientations and positon on the slot, incorrectly positioning a driver can cause the destruction of the board itself

- Disable printer from power and USB
- Remove the X Y Z stepper drivers from the board
- Remove the stepper driver of E1 (second extruder) and place on the X slot
- Enable printer
- Test the X axis motion
- Disable printer from power and USB
- Change the E1 stepper driver, now in X, to the Y axis slot
- Enable the printer
- Test the Y axis motion
- Disable printer from power and USB
- Change the E1 stepper driver, now in Y, to the Z axis slot
- Enable the printer
- Test the Z axis motion

Right now you should know which axis work correctly or not, if all 3 axis move correctly you should buy new stepper driver to replace the old ones, I recommend buying 5X A4988, available on our shop here: https://shop.beeverycreative.com/produc ... gro-a4988/ as they give you a better surface finish than the original DRV8825. If you replace them with A4988 you will need to make the changes in the firmware, we will provide you a pdf with instruction on how to do it.
They most likely got damaged by one failing and pushing some "noise" into the power line of the other drivers.

Please give me some feedback on the result from the test

Best regards
Domingos Rodrigues

Post Reply