Forum under maintenance. Please contact us at

"linear advance" looks like it won't work

This new DIY 3D printer kit is a result of a vast market research and hours of development and engineering. It is an open source project, which means this is a versatile product that you can build upon and make it your own.
Post Reply
Joined:10 Jul 2020, 11:01
"linear advance" looks like it won't work

Post by mechman » 10 Jul 2020, 19:37

Hello everyone.

I am novice in 3D printing but already did some good and bad experiences with the B2x300.
Until now i only read a lot in this forum and you help me a lot doing the first prints. First of all thank you for that !!

From the beginning i have some issues with under- and overextruding at the same print.
In the meantime i localized the problem at speed changes like corners or innerwall-outerwall. Especially on overhang-corners.
So i read about "linear advance" and wanted to try it out.
I´ve created a gcode file on but

all the printet lines looks the same. :?
the line width starts 0.44mm@slow then 0.38mm@fast then 0.44mm@ slow again with small blobs at the speed change.
the fast printed line never reach the adjusted 0.44 mm width.

I am using the "out of the box" hardware setup.
Because of the "Serial Number" issue i´ve directly used the B2X300 Firmwarre updater to upgrade to B2X300-20191202.
everything runs smoothly and firmly and the bed levels well. The exdtruders are calibrated.
For the test i take the beeverycreative PLA white and magenta which was included with the printer.
I set linear advance to version 1.0 first because if i read right it should be marlin 1.1.8 on it. (and the example gcode shwos a K value of 180)
I printed from K0 until K300 in different ways (e.g. K140-200 @ 5 Stepping...) -i´ve also tried V1.5 units and steps from 0 to 2. -with same results.
The fast speed is 40mm/s and the slow speed is 20mm/s. -Speed changes looks as expected but still the same scheme. (thick-thin-thick, with bigger or smaller blobs at the change point.)
Tried different nozzle hights. -from too low to too high.
Also tried to set the firmware acceleration and jerk to 0 for the print. -when I noticed the jerk is only adjustable to a minimum of 1 :?:
So I set jerk to 0 in the gcode instead of the -1 (which was the default).
Nothing helped for me so far.

I overlook something and hopefully we'll find it out together.

Joined:12 Dec 2017, 11:44

Re: "linear advance" looks like it won't work

Post by DomingosRodrigues » 01 Sep 2020, 13:56

Hello Mechman,

The B2X300 already has linear advance activated by default with a value tuned (180-225 if i'm not mistaken) to its extrusion system hence why you did not notice a significant change.

A jerk of 0 would be infinite rate of change that's why it cannot be set, if setting it in the gcode you are effectively disabling jerk control which isn't a good idea.

Can you please post some pictures of the defects you having so I can further help you?

Just in case try doing the following as most of the extrusion problems can be solved this way:
- Do 3x cold pull procedures on the nozzle you are using, the processing available on the LCD screen and have a quite easy to follow step by step guide on the LCD
- Ensure your filament oiler is correctly lubed with a significant amount of WD40.
- Ensure you are using the latest available firmware and printing profiles (you should use the profile for the MCPP filament for a good result)

I will be waiting on your feedback

Best regards
Domingos Rodrigues

Post Reply