B2X300 the printer from hell

This new DIY 3D printer kit is a result of a vast market research and hours of development and engineering. It is an open source project, which means this is a versatile product that you can build upon and make it your own.
DomingosRodrigues
Posts: 93
Joined: 12 Dec 2017, 11:44

Re: B2X300 the printer from hell

Post by DomingosRodrigues » 31 May 2019, 11:43

Hello wayne.kinne,

Yes that gcode is correctly configured, the fact that it isn't probing is really weird. If you can please verify all you motherboard cabling is correctly connected, with special attention to the part connected to the autocalibration servomotor and its endstop.
Then ensure you have the USB cable disabled and record a video of what happens when running that gcode, also film on a separae file what happens when you use the lcd screen to use the option "Machine settings" > "Level bed".

The first phase heats up the bed to temp and the hotend at 160ºC to avoid dripping plastic on the glass during the probing procedure, it will heat up to temperature and purge once the probing is completed. Please try the gcode as it comes out of cura before trying to change in order to make the debugging of what is happening easier.

Reflashing the machine isn't necessary if you already have the latest firmware, you can check that on the "About" screen, there should be a line saying "05/2019-master-6926a11".

Best regards
Domingos Rodrigues

User avatar
wayne.kinne
Posts: 9
Joined: 29 May 2019, 14:15

Re: B2X300 the printer from hell

Post by wayne.kinne » 31 May 2019, 17:24

I wont level, it did before the overheat thing.

uploaded a video to same: https://github.com/wkinne/wkinne

It did work at first, it printed half a part before the overtemp failure. It checked bed level before starting the print and everything. And it was printing a very nice looking part.

Running self test to see what happens.

Got this during self test, whats it mean?:

E1 Stepper driver :NOK

Error code: EC51

checking manual: E1 is my 2nd extruder? Wiring looks good and it was running yesterday sometimes even though it shouldn't have. It has no filament in it and never has. I do not think is the total problem, as I was not getting this error yesterday when running a selftest.

DomingosRodrigues
Posts: 93
Joined: 12 Dec 2017, 11:44

Re: B2X300 the printer from hell

Post by DomingosRodrigues » 03 Jun 2019, 10:16

Hello wayne.kinne,

As for the temperture error ensure your thermistor cables are correctly plugged to the board and that the bed's connector is well placed onto the bed PCB, if it has an intermittent connection it will throw a thermal runaway error to avoid the printer from overheating due to incorrect temperature measurement.

The EC51 error means the printer cannot communicate with the stepper drivers for that axis, it can happen due to a bad connection on the wires between the trinamic communication board and the board as shown on page 59 of the assembly manual available here:
https://beeverycreative.com/wp-content/ ... 190513.pdf
Reseat every connector and ensure they are securely seated in place, that should solve the EC51 error.

I've seen the video and that behavior is not normal, please contact customer_service@beeverycreative.com so we can schedule a teamviewer session to debug the printer and find out what is happening.

Best regards
Domingos Rodrigues

User avatar
wayne.kinne
Posts: 9
Joined: 29 May 2019, 14:15

Re: B2X300 the printer from hell

Post by wayne.kinne » 03 Jun 2019, 12:41

Thank you.

I re-seated every plug and still getting the error. Checked all the wiring, everything looks good. Contacting Customer Support.

Post Reply