[SOLVED) Endstopswitches always on !?!

The versatility of an entry-level 3D printer, engineered to last.
By BEEVERYCREATIVE and Hello 3D Printing World
Post Reply
João Ferreira
Posts: 69
Joined: 03 Aug 2017, 21:16

[SOLVED) Endstopswitches always on !?!

Post by João Ferreira » 09 Aug 2017, 18:38

Hi,

Anyone has a guess on why my X- , Z- endstopswitches are always on?

Only can move the X axis to the right..same with the Z axis (up)..the Y+ endstopswitch is working fine..

Even when they are disconected the X and the Z axis move only up and to the right..

I try to change their position on the board, disconect, already switch cables..

Any guess? do you think i have a broken board?
Last edited by João Ferreira on 10 Aug 2017, 19:06, edited 1 time in total.

MrDoom
Posts: 223
Joined: 01 Apr 2017, 10:01

Re: Endstopswitches always on !?!

Post by MrDoom » 10 Aug 2017, 09:40

Hello, have you checked this document here:
viewtopic.php?f=8&t=110

there is a fix about the endstops, they should only have two legs on the switch itself but sometimes have more and you need to cut one and then it should be fine :)

João Ferreira
Posts: 69
Joined: 03 Aug 2017, 21:16

Re: Endstopswitches always on !?!

Post by João Ferreira » 10 Aug 2017, 15:09

yes, I already checked those fix recomendations..
My switches only have 2 (of 3) of those NC terminals, so, they are ok..they are working fine when they are conected to the Y+ port..only the X- and Z- show that something is not right..(in fact, all X+, Y-, Y+, Z+ ports don´t light up the endstopswitches)

I think maybe there is a short circuit somewhere in my board, but this is the first time that i had a close look at a board anyway..so...

I already contact de support team from HbP..they ask me for some pictures..

MrDoom
Posts: 223
Joined: 01 Apr 2017, 10:01

Re: Endstopswitches always on !?!

Post by MrDoom » 10 Aug 2017, 16:24

ahhh okay that's different, I guess there is some problem with your board, probably the place where you connect the endstops to.
The printer wont move the other way because it thinks it is hitting the endstop :/
Wait for their reply, they usually solve the problem either by advising you how to fix it or sending new material to fix the broken parts.

João Ferreira
Posts: 69
Joined: 03 Aug 2017, 21:16

Re: Endstopswitches always on !?!

Post by João Ferreira » 10 Aug 2017, 19:06

SOLVED.

A new firmware update, and change the X- and Z- conections to X+ and Z+ ports, to prove the board had a problem.

Post Reply