Page 1 of 1

Error Code EC51 after firmware update

Posted: 25 Apr 2019, 19:11
by TracyJonSargeant
After assembling the 3d printer I ran through the self-test wizard and it went through most of the wizard and received a message about the bed. I noticed that the Z motors never moved during the self-test. I emailed support and received the instructions to update the firmware and perform some other innocuous steps. Now when I run the self-test wizard it stops right at the Z stepper driver test with error code EC51.

Has anyone else run into this issue or have suggestions on how to resolve? B2X300 support is not awesome and takes 24+ hours to reply.

Re: Error Code EC51 after firmware update

Posted: 26 Apr 2019, 18:23
by srodrigues
Hello @TracyJonSargeant!

In fact, yesterday was a national holiday in Portugal, and some of our staff members have required holidays these days. This is why there is some delay this week.

Please check the chapter 9 on the user manual of B2X300, there you can see a list of the error shown on self test wizard and the respective solution you can try : https://beeverycreative.com/manuals-tutorials/

Thank you for your contact,
Sílvia

Re: Error Code EC51 after firmware update

Posted: 28 Apr 2019, 16:38
by DomingosRodrigues
Hello TracyJonSargeant,

Adding to what Silvia mentioned, the error you have is due to a problem with a stepper driver, most likely a bad connection between either the communication board (white board bellow the air channel on the motherboard) and the stepper drivers (small white chips on the motherboard bellow the communication board) or the communication board and the motherboard on the two flat cables that connect one to another.
I would suggest removing the air channel, removing the communication board, and removing the problematic stepper driver the Z axis (third from the top) and replacing it with E2 stepper driver (fifth from the top), be careful with the orientation and if all the pins enter the correct slots, then reinstall the communication board, once again taking care that all the pins on all stepper drivers fit on the slots on the communication board, reinstall the air channel and test again, this will either solve the issue or change the error to E2, please give some feedback once you test this :)

FIY the new firmware did not break the stepper driver but the new firmware has much more intensive tests to the stepper drivers and finds problems that passed the test on latest releases, this is made to avoid damage to the printer and user during operation.

Best regards